[bug#34824,staging] libdrm/Mesa Meson patch series

Message ID 20190318162545.4d746971@mykolab.com
State Accepted
Headers show
Series [bug#34824,staging] libdrm/Mesa Meson patch series | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Rutger Helling March 18, 2019, 3:25 p.m. UTC
I think you're right! Changing mesa from a regular input to a
propogated one seems to have fixed all the issues for SDL. I no longer
need patches 3-6. See below for what we can use instead. Can I push the
patches now?

* gnu/packages/sdl.scm (sdl)[propogated-inputs]: Add mesa.
[inputs]: Remove mesa.
---
 gnu/packages/sdl.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Marius Bakke March 18, 2019, 4:50 p.m. UTC | #1
Rutger Helling <rhelling@mykolab.com> writes:

> I think you're right! Changing mesa from a regular input to a
> propogated one seems to have fixed all the issues for SDL. I no longer
> need patches 3-6. See below for what we can use instead. Can I push the
> patches now?

Well, we still don't know *why* it is needed :-)

Could you add a comment about where it comes from (e.g. pkg-config or
the .la files) and squash this commit with the Mesa patch?  LGTM with
that change, thanks!
Rutger Helling March 19, 2019, 10:10 a.m. UTC | #2
Done, along with an update to 18.3.5.

On Mon, 18 Mar 2019 17:50:07 +0100
Marius Bakke <mbakke@fastmail.com> wrote:

> Rutger Helling <rhelling@mykolab.com> writes:
> 
> > I think you're right! Changing mesa from a regular input to a
> > propogated one seems to have fixed all the issues for SDL. I no
> > longer need patches 3-6. See below for what we can use instead. Can
> > I push the patches now?  
> 
> Well, we still don't know *why* it is needed :-)
> 
> Could you add a comment about where it comes from (e.g. pkg-config or
> the .la files) and squash this commit with the Mesa patch?  LGTM with
> that change, thanks!

Patch

From b46743817e2bd5d1a8bd266f3b5ad27799468a87 Mon Sep 17 00:00:00 2001
From: Rutger Helling <rhelling@mykolab.com>
Date: Mon, 18 Mar 2019 16:11:41 +0100
Subject: [PATCH] gnu: sdl: Propogate mesa input.

* gnu/packages/sdl.scm (sdl)[propogated-inputs]: Add mesa.
[inputs]: Remove mesa.
---
 gnu/packages/sdl.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 8d2a02437..e13958984 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -87,10 +87,10 @@ 
     (propagated-inputs
      ;; SDL headers include X11 headers.
      `(("libx11" ,libx11)
-       ("libcap" ,libcap))) ; 'libSDL.la' contain `-lcap'.
+       ("libcap" ,libcap) ; 'libSDL.la' contain `-lcap'.
+       ("mesa" ,mesa)))
     (native-inputs `(("pkg-config" ,pkg-config)))
     (inputs `(("libxrandr" ,libxrandr)
-              ("mesa" ,mesa)
               ("glu" ,glu)
               ("alsa-lib" ,alsa-lib)
               ("pulseaudio" ,pulseaudio)))
-- 
2.21.0