[bug#34899] gnu: Add python-shortuuid.

Message ID 20190317180829.13909-1-smbaines8@gmail.com
State Accepted
Headers show
Series [bug#34899] gnu: Add python-shortuuid. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Sam March 17, 2019, 6:08 p.m. UTC
* gnu/packages/python-xyz.scm (python-shortuuid): New variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Leo Famulari March 18, 2019, 4:59 p.m. UTC | #1
On Sun, Mar 17, 2019 at 06:08:29PM +0000, Sam wrote:
> * gnu/packages/python-xyz.scm (python-shortuuid): New variable.

Thanks! Pushed as a91f4eba2c923405ccdce5bdb390b12a40a856c2

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fa2701bc1c..c3a60058f2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -229,6 +229,28 @@  pidof, tty, taskset, pmap.")
 planar geometric objects.  It is based on the @code{GEOS} library.")
     (license license:bsd-3)))
 
+(define-public python-shortuuid
+  (package
+    (name "python-shortuuid")
+    (version "0.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "shortuuid" version))
+       (sha256
+        (base32
+         "1f8i4zwj5vmpzbz6b17bljy4399gx5aq7vsyw63sz2qgyjcd73yh"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-pep8" ,python-pep8)))
+    (home-page "https://github.com/skorokithakis/shortuuid")
+    (synopsis "Generator library for concise, unambiguous and URL-safe UUIDs")
+    (description
+     "@code{shortuuid} is a Python library for generating concise, unambiguous
+and URL-safe UUIDs.  UUIDs are generated using the built-in Python @code{uuid}
+module and then similar looking characters are removed.")
+    (license license:bsd-3)))
+
 (define-public python-logwrap
   (package
     (name "python-logwrap")