[bug#34189] gnu: Add arcan.

Message ID cuczhpzt400.fsf@lprndn.info
State Accepted
Headers show
Series [bug#34189] gnu: Add arcan. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

L p R n d n March 13, 2019, 11:20 a.m. UTC
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

[...]
>
> Sorry that this is taking so long, but at least we’re making progress!
> :-)
>
> Ludo’.

Don't worry I'm not very quick to answer myself and as long as we're
going forward, everything should be fine.

I join new patches for xarcan and arcan-wayland.

Thanks for your help!

Lprndn

Comments

Ludovic Courtès March 18, 2019, 9:37 a.m. UTC | #1
Hello,

L  p R n  d n    <guix@lprndn.info> skribis:

> I join new patches for xarcan and arcan-wayland.

Perfect, I’ve applied both!

Are we done?

Thank you,
Ludo’.
L p R n d n March 18, 2019, 11:02 a.m. UTC | #2
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

> Hello,
>
> L  p R n  d n    <guix@lprndn.info> skribis:
>
>> I join new patches for xarcan and arcan-wayland.
>
> Perfect, I’ve applied both!
>
> Are we done?
>
> Thank you,
> Ludo’.


Sorry, there are still aclip, aloadimage and durden. I didn't send a new
patch because they were not impacted by the previous changes. Do you
want me to send them again?

Thank you very much!

Lprndn

Patch

From eef364a45e520a6a9b34172b1ae0455d77a6c769 Mon Sep 17 00:00:00 2001
From: Lprndn <guix@lprndn.info>
Date: Thu, 24 Jan 2019 13:41:30 +0100
Subject: [PATCH] gnu: Add arcan-wayland.

* gnu/packages/arcan.scm (arcan-wayland): New variable.
---
 gnu/packages/arcan.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/arcan.scm b/gnu/packages/arcan.scm
index c7c81241f0..b59e5637be 100644
--- a/gnu/packages/arcan.scm
+++ b/gnu/packages/arcan.scm
@@ -30,11 +30,13 @@ 
   #:use-module (gnu packages compression)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages fontutils)
+  #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image)
   #:use-module (gnu packages libusb)
+  #:use-module (gnu packages linux)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages ocr)
   #:use-module (gnu packages pcre)
@@ -249,3 +251,35 @@  engine programmable using Lua.")
  to map Xlib/Xcb/X clients to a running arcan instance.  It allows running an X session
 as a window under Arcan.")
       (license license:expat))))
+
+(define-public arcan-wayland
+  (package
+    (inherit arcan)
+    (name "arcan-wayland")
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("arcan" ,arcan)
+       ("libseccomp" ,libseccomp)
+       ("libxkbcommon" ,libxkbcommon)
+       ("mesa" ,mesa)
+       ("wayland" ,wayland)
+       ("wayland-protocols" ,wayland-protocols)))
+    (arguments
+     `(#:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'chdir
+           (lambda _
+             (chdir "src/tools/waybridge")
+             #t))
+         (add-after 'unpack 'fix-cmake-find-shmif
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "src/platform/cmake/modules/Findarcan_shmif.cmake"
+               (("/usr/local") (assoc-ref inputs "arcan")))
+             #t)))))
+    (synopsis "Wayland protocol service for Arcan")
+    (description "Arcan-wayland (waybridge) bridges Wayland connections
+with an Arcan connection point.  It allows Wayland compatible clients
+to connect and render using Arcan.")
+    (license license:bsd-3)))
-- 
2.20.1