[bug#34824,staging] libdrm/Mesa Meson patch series

Message ID 20190312141615.2d96bb7d@mykolab.com
State Accepted
Headers show
Series [bug#34824,staging] libdrm/Mesa Meson patch series | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Rutger Helling March 12, 2019, 1:16 p.m. UTC
Hey Guix,

this patch series changes libdrm and Mesa to use Meson.

A few notes to go along with the patches:

Patch #1: Libdrm on Github mentions that Autotools is the legacy build
system for libdrm, so it seems better to change this to use Meson.
Patch #2: Mesa is gonna drop support for Autotools entirely at some
point in 2019, so it seems good to make the switch sooner rather than
later. I think I converted all the configure flags to the new format.
Patches #3-6: For some reason these packages now need an explicit mesa
input. I haven't run into other packages that have this problem yet.

Comments

Marius Bakke March 17, 2019, 6:01 p.m. UTC | #1
Rutger Helling <rhelling@mykolab.com> writes:

> Hey Guix,
>
> this patch series changes libdrm and Mesa to use Meson.
>
> A few notes to go along with the patches:
>
> Patch #1: Libdrm on Github mentions that Autotools is the legacy build
> system for libdrm, so it seems better to change this to use Meson.
> Patch #2: Mesa is gonna drop support for Autotools entirely at some
> point in 2019, so it seems good to make the switch sooner rather than
> later. I think I converted all the configure flags to the new format.
> Patches #3-6: For some reason these packages now need an explicit mesa
> input. I haven't run into other packages that have this problem yet.

The first two patches LGTM, but we should figure out why some packages
need special attention and squash the fixes with the Mesa (or libdrm)
change.

I see the other packages are SDL-related, maybe the libSDL pkg-config
files are different after this change?  Or "sdl-config" prints something
weird?

Thanks for looking after these packages :-)
Rutger Helling March 18, 2019, 9:44 a.m. UTC | #2
Hi Marius,

thanks for the review.

So when I rebuilt my entire system a while back with these patches it
was only those few SDL packages that were affected. Unfortunately I have
no way of knowing for sure if it won't happen anywhere else, but it
does seem to be something contained to just SDL(1).

The packages fail with the following error if "mesa" isn't an explicit
input:

ld: cannot find -lGL
collect2: error: ld returned 1 exit status

WDYT? Should I go ahead and push these patches or do you have other
ideas?

On Sun, 17 Mar 2019 19:01:59 +0100
Marius Bakke <mbakke@fastmail.com> wrote:

> Rutger Helling <rhelling@mykolab.com> writes:
> 
> > Hey Guix,
> >
> > this patch series changes libdrm and Mesa to use Meson.
> >
> > A few notes to go along with the patches:
> >
> > Patch #1: Libdrm on Github mentions that Autotools is the legacy
> > build system for libdrm, so it seems better to change this to use
> > Meson. Patch #2: Mesa is gonna drop support for Autotools entirely
> > at some point in 2019, so it seems good to make the switch sooner
> > rather than later. I think I converted all the configure flags to
> > the new format. Patches #3-6: For some reason these packages now
> > need an explicit mesa input. I haven't run into other packages that
> > have this problem yet.  
> 
> The first two patches LGTM, but we should figure out why some packages
> need special attention and squash the fixes with the Mesa (or libdrm)
> change.
> 
> I see the other packages are SDL-related, maybe the libSDL pkg-config
> files are different after this change?  Or "sdl-config" prints
> something weird?
> 
> Thanks for looking after these packages :-)
Marius Bakke March 18, 2019, 2:17 p.m. UTC | #3
Rutger Helling <rhelling@mykolab.com> writes:

> Hi Marius,
>
> thanks for the review.
>
> So when I rebuilt my entire system a while back with these patches it
> was only those few SDL packages that were affected. Unfortunately I have
> no way of knowing for sure if it won't happen anywhere else, but it
> does seem to be something contained to just SDL(1).
>
> The packages fail with the following error if "mesa" isn't an explicit
> input:
>
> ld: cannot find -lGL
> collect2: error: ld returned 1 exit status
>
> WDYT? Should I go ahead and push these patches or do you have other
> ideas?

Well, we still don't know why -lGL is suddenly there.  Did you inspect
the pkg-config files or sdl-config output to figure out why?

I suspect Mesa should be propagated somewhere, instead of added as an
input in a bunch of places.

Patch

From fd059a1b42a5ba4b21ffe996d65159fa93736bee Mon Sep 17 00:00:00 2001
From: Rutger Helling <rhelling@mykolab.com>
Date: Tue, 12 Mar 2019 12:55:25 +0100
Subject: [PATCH 4/4] gnu: sdl-net: Add mesa input.

* gnu/packages/sdl.scm (sdl-net)[inputs]: Add "mesa".
---
 gnu/packages/sdl.scm | 1 +
 1 file changed, 1 insertion(+)

diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 634b77648..0c4a5bee1 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -286,6 +286,7 @@  MIDI, Ogg Vorbis, and MP3.")
     (build-system gnu-build-system)
     (propagated-inputs `(("sdl" ,sdl)))
     (native-inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("mesa" ,mesa)))
     (outputs '("out" "debug"))
     (synopsis "SDL networking library")
     (description "SDL_net is a small, cross-platform networking library for
-- 
2.21.0