[bug#34696] gnu: add r-rematch2.

Message ID 20190301080758.5548-4-anothersms@gmail.com
State Accepted
Headers show
Series [bug#34696] gnu: add r-rematch2. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Nicolò Balzarotti March 1, 2019, 8:07 a.m. UTC
---
 gnu/packages/cran.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Ricardo Wurmus March 14, 2019, 9:58 a.m. UTC | #1
Hi Nicolò,

thank you for this patch.  I applied it with
100f56024e72ad5effff340d34cd7a91a34a830a after a few changes:

- the description now contains full sentences
- 'regexpr' and 'gregexpr' have been wrapped in @code{}
- I added a proper commit message (with the “add” Yasnippet in Emacs)
- I added a copyright line for you
- the words in the synopsis are now lowercase
- I removed the #readme tag from the home-page field
- adjusted the indentation

Thanks!

--
Ricardo

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a9b775f67e..6ab5ecc8da 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10757,3 +10757,23 @@  using @code{S3}.")
      "Checks adherence to a given style, syntax errors and possible semantic issues.  Supports on the fly checking of R code edited with 'RStudio IDE', 'Emacs', 'Vim', 'Sublime Text' and 'Atom'.")
     (license license:expat)))
 
+(define-public r-rematch2
+  (package
+    (name "r-rematch2")
+    (version "2.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "rematch2" version))
+       (sha256
+        (base32
+         "16k0i5p7fa3qfxv59ijyn638wpz8n4jrkrnilqmh5g9l8f8bn4h6"))))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-tibble" ,r-tibble)))
+    (home-page
+     "https://github.com/r-lib/rematch2#readme")
+    (synopsis
+     "Tidy Output from Regular Expression Matching")
+    (description
+     "Wrappers on 'regexpr' and 'gregexpr' to return the match results in tidy data frames.")
+    (license license:expat)))