Message ID | 6ed05370c7216eaed5c08739a611e774adc3811b.1550437064.git.leo@famulari.name |
---|---|
State | Accepted |
Commit | d5bbf66d71322fc9bc32adfeb41ab733ec47502b |
Headers | show |
Series | [bug#34515,01/13] gnu: Add python-humanize. | expand |
Context | Check | Description |
---|---|---|
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
Leo Famulari <leo@famulari.name> writes:
> * gnu/packages/python-xyz.scm (python-txaio): New variable.
LGTM!
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm index decfb01117..745569c14a 100644 --- a/gnu/packages/python-xyz.scm +++ b/gnu/packages/python-xyz.scm @@ -15065,3 +15065,24 @@ make your work easier.") and dates in \"human readable\" forms. For example, it would display \"12345591313\" as \"12.3 billion\".") (license license:expat))) + +(define-public python-txaio + (package + (name "python-txaio") + (version "18.8.1") + (source + (origin + (method url-fetch) + (uri (pypi-uri "txaio" version)) + (sha256 + (base32 + "1zmpdph6zddgrnkkcykh6qk5s46l7s5mzfqrh82m4b5iffn61qv7")))) + (build-system python-build-system) + (propagated-inputs + `(("python-twisted" ,python-twisted) + ("python-six" ,python-six))) + (home-page "https://github.com/crossbario/txaio") + (synopsis "Compatibility layer between Python asyncio and Twisted") + (description "Txaio provides a compatibility layer between the Python +@code{asyncio} module and @code{Twisted}.") + (license license:expat)))