[bug#34371] gnu: emacs: Add modules support.

Message ID 20190207164347.4199-1-contact@parouby.fr
State Accepted
Commit 94be7c8b2aad43a311bc210104637b31515f80a1
Headers show
Series [bug#34371] gnu: emacs: Add modules support. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

parouby Feb. 7, 2019, 4:43 p.m. UTC
* gnu/packages/emacs.scm (emacs): Add modules support in configure-flags.
---
 gnu/packages/emacs.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

Ludovic Courtès Feb. 15, 2019, 9:16 p.m. UTC | #1
Hello Pierre-Antoine,

Pierre-Antoine Rouby <contact@parouby.fr> skribis:

> * gnu/packages/emacs.scm (emacs): Add modules support in configure-flags.
> ---
>  gnu/packages/emacs.scm | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 7e8dcadf9..40d280f3e 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -115,6 +115,7 @@
>      (build-system glib-or-gtk-build-system)
>      (arguments
>       `(#:tests? #f  ; no check target
> +       #:configure-flags (list "--with-modules")

What effect does it have?  (I guess I’m a noob!)

If the Emacsfolks among us are fine with it, then so be it!

Thank you,
Ludo’.
Ricardo Wurmus Feb. 18, 2019, 10:58 p.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Hello Pierre-Antoine,
>
> Pierre-Antoine Rouby <contact@parouby.fr> skribis:
>
>> * gnu/packages/emacs.scm (emacs): Add modules support in configure-flags.
>> ---
>>  gnu/packages/emacs.scm | 1 +
>>  1 file changed, 1 insertion(+)
>>
>> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
>> index 7e8dcadf9..40d280f3e 100644
>> --- a/gnu/packages/emacs.scm
>> +++ b/gnu/packages/emacs.scm
>> @@ -115,6 +115,7 @@
>>      (build-system glib-or-gtk-build-system)
>>      (arguments
>>       `(#:tests? #f  ; no check target
>> +       #:configure-flags (list "--with-modules")
>
> What effect does it have?  (I guess I’m a noob!)
>
> If the Emacsfolks among us are fine with it, then so be it!

This allows one to build and load native C modules.  It’s a heavy-weight
extension mechanism (that one could use to extend Emacs with Guile
support, for example).

I don’t object to this change.
Brett Gilio Feb. 18, 2019, 11:05 p.m. UTC | #3
Ricardo Wurmus writes:

> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Hello Pierre-Antoine,
>>
>> Pierre-Antoine Rouby <contact@parouby.fr> skribis:
>>
>>> * gnu/packages/emacs.scm (emacs): Add modules support in configure-flags.
>>> ---
>>>  gnu/packages/emacs.scm | 1 +
>>>  1 file changed, 1 insertion(+)
>>>
>>> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
>>> index 7e8dcadf9..40d280f3e 100644
>>> --- a/gnu/packages/emacs.scm
>>> +++ b/gnu/packages/emacs.scm
>>> @@ -115,6 +115,7 @@
>>>      (build-system glib-or-gtk-build-system)
>>>      (arguments
>>>       `(#:tests? #f  ; no check target
>>> +       #:configure-flags (list "--with-modules")
>>
>> What effect does it have?  (I guess I’m a noob!)
>>
>> If the Emacsfolks among us are fine with it, then so be it!
>
> This allows one to build and load native C modules.  It’s a heavy-weight
> extension mechanism (that one could use to extend Emacs with Guile
> support, for example).
>
> I don’t object to this change.

Agreed with Ricardo,

I think this change is great, it is something I have been doing in my
own recipe for Emacs. Move it upstream, for sure.

Brett Gilio
Ludovic Courtès March 4, 2019, 1:40 p.m. UTC | #4
Hi,

Ricardo Wurmus <rekado@elephly.net> skribis:

> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Hello Pierre-Antoine,
>>
>> Pierre-Antoine Rouby <contact@parouby.fr> skribis:
>>
>>> * gnu/packages/emacs.scm (emacs): Add modules support in configure-flags.
>>> ---
>>>  gnu/packages/emacs.scm | 1 +
>>>  1 file changed, 1 insertion(+)
>>>
>>> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
>>> index 7e8dcadf9..40d280f3e 100644
>>> --- a/gnu/packages/emacs.scm
>>> +++ b/gnu/packages/emacs.scm
>>> @@ -115,6 +115,7 @@
>>>      (build-system glib-or-gtk-build-system)
>>>      (arguments
>>>       `(#:tests? #f  ; no check target
>>> +       #:configure-flags (list "--with-modules")
>>
>> What effect does it have?  (I guess I’m a noob!)
>>
>> If the Emacsfolks among us are fine with it, then so be it!
>
> This allows one to build and load native C modules.  It’s a heavy-weight
> extension mechanism (that one could use to extend Emacs with Guile
> support, for example).
>
> I don’t object to this change.

Alright, applied.

Thanks Ricardo and Brett for chiming in!

Ludo’.

Patch

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7e8dcadf9..40d280f3e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -115,6 +115,7 @@ 
     (build-system glib-or-gtk-build-system)
     (arguments
      `(#:tests? #f  ; no check target
+       #:configure-flags (list "--with-modules")
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'fix-/bin/pwd