[bug#33298] gnu: clementine: Build with sqlite-with-column-metadata.

Message ID cublg65xlzw.fsf@gmx.com
State Accepted
Headers show
Series [bug#33298] gnu: clementine: Build with sqlite-with-column-metadata. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Pierre Langlois Nov. 7, 2018, 9:41 a.m. UTC
Hi Guix!

Clementine's tests failed with the recent Qt update:

~~~
[==========] Running 3 tests from 1 test case.
[----------] Global test environment set-up.
[----------] 3 tests from ScopedTransactionTest
[ RUN      ] ScopedTransactionTest.OpensATransaction
13:37:41.705 WARN  ScopedTransaction:33             Rolling back transaction
[       OK ] ScopedTransactionTest.OpensATransaction (2 ms)
[ RUN      ] ScopedTransactionTest.RollbackOnDtor
./scopedtransaction_test: symbol lookup error: /gnu/store/433p4vnzb49xavq28ghyj8zpxml9x6b3-qtbase-5.11.2/lib/qt5/plugins/sqldrivers/libqsqlite.so: undefined symbol: sqlite3_column_table_name16
~~~

It looks like it was due to removing the bundled sqlite from Qt and
using the 'sqlite-with-column-metadata' package for clementine fixes the issue.

Thanks!
Pierre

Comments

Leo Famulari Nov. 7, 2018, 7:25 p.m. UTC | #1
On Wed, Nov 07, 2018 at 09:41:55AM +0000, Pierre Langlois wrote:
> Hi Guix!
> 
> Clementine's tests failed with the recent Qt update:
> 
> ~~~
> [==========] Running 3 tests from 1 test case.
> [----------] Global test environment set-up.
> [----------] 3 tests from ScopedTransactionTest
> [ RUN      ] ScopedTransactionTest.OpensATransaction
> 13:37:41.705 WARN  ScopedTransaction:33             Rolling back transaction
> [       OK ] ScopedTransactionTest.OpensATransaction (2 ms)
> [ RUN      ] ScopedTransactionTest.RollbackOnDtor
> ./scopedtransaction_test: symbol lookup error: /gnu/store/433p4vnzb49xavq28ghyj8zpxml9x6b3-qtbase-5.11.2/lib/qt5/plugins/sqldrivers/libqsqlite.so: undefined symbol: sqlite3_column_table_name16
> ~~~
> 
> It looks like it was due to removing the bundled sqlite from Qt and
> using the 'sqlite-with-column-metadata' package for clementine fixes the issue.
> 
> Thanks!
> Pierre
> 

> From 08bf3ffce142e4fc1a1ef126c30f32387c581fc5 Mon Sep 17 00:00:00 2001
> From: Pierre Langlois <pierre.langlois@gmx.com>
> Date: Wed, 7 Nov 2018 09:31:18 +0000
> Subject: [PATCH] gnu: clementine: Build with sqlite-with-column-metadata.
> 
> * gnu/packages/music.scm (clementine)[inputs]: Use
> sqlite-with-column-metadata.

Thanks! Pushed as f09e8abc5e6b115e497d49bdf7e1fb98ebfd8caf.

Patch

From 08bf3ffce142e4fc1a1ef126c30f32387c581fc5 Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Wed, 7 Nov 2018 09:31:18 +0000
Subject: [PATCH] gnu: clementine: Build with sqlite-with-column-metadata.

* gnu/packages/music.scm (clementine)[inputs]: Use
sqlite-with-column-metadata.
---
 gnu/packages/music.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index cdd06647e1..7f1d124233 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -284,7 +284,7 @@  score, keyboard, guitar, drum and controller views.")
          ("pulseaudio" ,pulseaudio)
          ("qtbase" ,qtbase)
          ("qtx11extras" ,qtx11extras)
-         ("sqlite" ,sqlite)
+         ("sqlite" ,sqlite-with-column-metadata)
          ("sparsehash" ,sparsehash)
          ("taglib" ,taglib)))
       (home-page "http://clementine-player.org")
-- 
2.19.1