[bug#34232] gnu: rust: Package rust@1.29.2

Message ID B2EFC7C1-2170-427A-9085-DE8BF7857DCC@gmail.com
State Accepted
Commit 0e9811f4a3a30c3496b17be78635b32bb0318835
Headers show
Series [bug#34232] gnu: rust: Package rust@1.29.2 | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Ivan Petkov Jan. 28, 2019, 6:50 a.m. UTC
* gnu/packages/rust.scm (rust): renamed to rust-1.28
* gnu/packages/rust.scm (rust): Packaged rust@1.29.2 by inheriting from
rust@1.28.0 and only applying the necessary patches which were lacking
upstream
---
 gnu/packages/rust.scm | 12 +++++++++++-
 1 file changed, 11 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès Feb. 6, 2019, 10:06 p.m. UTC | #1
Hello Ivan,

Ivan Petkov <ivanppetkov@gmail.com> skribis:

> * gnu/packages/rust.scm (rust): renamed to rust-1.28
> * gnu/packages/rust.scm (rust): Packaged rust@1.29.2 by inheriting from
> rust@1.28.0 and only applying the necessary patches which were lacking
> upstream

Thanks for your patch!  I’ll leave the last word to Danny but this LGTM.

Danny, WDYT?  Please apply if you think it’s good.

Ludo’.
Ivan Petkov Feb. 14, 2019, 3:51 a.m. UTC | #2
> Thanks for your patch!  I’ll leave the last word to Danny but this LGTM.
> 
> Danny, WDYT?  Please apply if you think it’s good.


Hey Danny,

Did you have any feedback on this?

FWIW I’ve also started working on packaging rust-1.30.1 but that one needs
some local patching and I haven’t quite finished fleshing all the changes
out.

Happy to merge the patches if you think that's better for doing one upgrade
of the rust compiler, but I'm also open to keeping them separate if that's
easier to review!

Thanks,
--Ivan
Danny Milosavljevic Feb. 14, 2019, 4:57 p.m. UTC | #3
Hi Ivan,

On Wed, 13 Feb 2019 19:51:53 -0800
Ivan Petkov <ivanppetkov@gmail.com> wrote:

> Did you have any feedback on this?

Yes, I've applied it to master.

Thanks!

Patch

diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 501736d89..179689973 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -749,7 +749,7 @@  jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
                    (("fn thin_lto_works") "#[ignore]\nfn thin_lto_works"))
                  #t)))))))))
 
-(define-public rust
+(define-public rust-1.28
   (let ((base-rust
          (rust-bootstrapped-package rust-1.27 "1.28.0"
                                     "11k4rn77bca2rikykkk9fmprrgjswd4x4kaq7fia08vgkir82nhx"
@@ -782,3 +782,13 @@  jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
                  #t))
              ;; The thinlto test should pass with llvm 6.
              (delete 'disable-thinlto-test))))))))
+
+(define-public rust
+  (let ((base-rust
+         (rust-bootstrapped-package rust-1.28 "1.29.2"
+                                    "1jb787080z754caa2w3w1amsygs4qlzj9rs1vy64firfmabfg22h"
+                                    #:patches
+                                    '("rust-1.25-accept-more-detailed-gdb-lines.patch"
+                                      "rust-reproducible-builds.patch"))))
+    (package
+      (inherit base-rust))))