diff mbox series

[bug#63894,24/55] gnu: Add perl-gd.

Message ID 20230604174249.30044-24-antero@mailbox.org
State New
Headers show
Series [bug#63894,01/55] gnu: perl-dbix-class: Update to 0.082843. | expand

Commit Message

Antero Mejr June 4, 2023, 5:42 p.m. UTC
* gnu/packages/perl.scm (perl-gd): New variable.
---
 gnu/packages/perl.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 42566ce724..f4f0a16ea8 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5528,6 +5528,28 @@  (define-public perl-function-parameters
 from having to unpack @code{@@_} manually, but this module can do much more.")
     (license license:perl-license)))
 
+(define-public perl-gd
+  (package
+    (name "perl-gd")
+    (version "2.77")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://cpan/authors/id/R/RU/RURBAN/GD-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "1dbg040nkbv8jjgabzjpmay5ysvg3cgxsqmv5771dq1vxyw8hv5m"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-extutils-pkgconfig perl-test-fork))
+    (inputs (list gd))
+    (home-page "https://metacpan.org/release/GD")
+    (synopsis "Perl interface to the libgd graphics library")
+    (description
+     "@file{GD.pm} is a Perl interface to the gd graphics library.  GD allows
+you to create color drawings using a large number of graphics primitives, and
+emit the drawings as PNG files.")
+    (license license:perl-license)))
+
 (define-public perl-getopt-argvfile
   (package
     (name "perl-getopt-argvfile")