diff mbox series

[bug#63894,15/55] gnu: Add perl-constant.

Message ID 20230604174249.30044-15-antero@mailbox.org
State New
Headers show
Series [bug#63894,01/55] gnu: perl-dbix-class: Update to 0.082843. | expand

Commit Message

Antero Mejr June 4, 2023, 5:42 p.m. UTC
* gnu/packages/perl.scm (perl-constant): New variable.
---
 gnu/packages/perl.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 4d456d0f06..d2c41cbc12 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2178,6 +2178,28 @@  (define-public perl-const-fast
 scalars, arrays, and hashes.")
     (license (package-license perl))))
 
+(define-public perl-constant
+  (package
+    (name "perl-constant")
+    (version "1.33")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://cpan/authors/id/R/RJ/RJBS/constant-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "015my616h5l2fswh52x4dp3n007gk5lax83ww9q6cmzb610mv5kr"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/release/constant")
+    (synopsis "Perl pragma to declare constants")
+    (description
+     "This pragma allows you to declare constants at compile-time.  When a
+constant is used in an expression, Perl replaces it with its value at compile
+time, and may then optimize the expression further.  In particular, any code
+in an @code{if (CONSTANT)} block will be optimized away if the constant is
+false.")
+    (license license:perl-license)))
+
 (define-public perl-context-preserve
   (package
     (name "perl-context-preserve")