diff mbox series

[bug#57999] gnu: Add textpieces

Message ID zpY3eWupENESH69mFgO7pNhk1_H7Dl9K5SX2ubtSGbtJIH_f7BvXOsCNjkOdw-aOjz-C8C7hWe8K6yhyPiEXXpGRPDQeH538igNe8V5-Yko=@proton.me
State Accepted
Headers show
Series [bug#57999] gnu: Add textpieces | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sughosha Sept. 22, 2022, 6:23 a.m. UTC
From: Sughosha <sughosha@proton.me>

* gnu/packages/text-editors.scm (textpieces): New variable.
---
 gnu/packages/text-editors.scm | 55 +++++++++++++++++++++++++++++++++++
 1 file changed, 55 insertions(+)

Comments

Maxim Cournoyer Sept. 28, 2022, 5:26 p.m. UTC | #1
Hello,

Sughosha <Sughosha@proton.me> writes:

> From: Sughosha <sughosha@proton.me>
>
> * gnu/packages/text-editors.scm (textpieces): New variable.

[...]

> +(define-public textpieces
> +  (package
> +    (name "textpieces")
> +    (version "3.2.0")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/liferooter/textpieces")
> +                    (commit (string-append "v" version))))
> +              (sha256
> +               (base32
> +                "14zq2c7js80m4cq8wpdb3kyz5sw96l8znbz027w8s94gqhm632ff"))))
> +    (arguments
> +     `(#:tests? #f ;fails to validate appstream file

Is this a known issue upstream?  If so, it should be linked with a full
sentence, for example: "The test suite fails validating the appstream
file (see: https://www.upstream-issue-url)."

> +       #:glib-or-gtk? #t))
> +    (build-system meson-build-system)
> +    (native-inputs (list pkg-config
> +                         vala
> +                         desktop-file-utils
> +                         appstream-glib
> +                         gettext-minimal
> +                         `(,glib "bin")
> +                         blueprint-compiler
> +                         `(,gtk "bin")))
> +    (inputs (list gtk
> +                  libadwaita
> +                  gtksourceview
> +                  json-glib
> +                  libgee
> +                  python
> +                  python-pygobject
> +                  python-pyyaml))

Please sort the dependencies in lexicographical order.

> +    (home-page "https://github.com/liferooter/textpieces")
> +    (synopsis "Quick text processor")
> +    (description
> +     "Text Pieces tool for quick text transformations such as checksums,

                    ^ is a tool
                    
> +encoding, decoding and so on.
                     ^, etc.

> +The basic features of Text Pieces are:
> +@itemize
> +@item Base64 encoding and decoding
> +@item SHA-1, SHA-2 and MD5 checksums
> +@item Prettify and minify JSON
> +@item Covert JSON to YAML and vice versa
> +@item Count lines, symbols and words
> +@item Escape and unescape string, URL and HTML
> +@item Remove leading and trailing whitespaces
> +@item Sort and reverse sort lines
> +@item Reverse lines and whole text
> +@item You can write your own scripts and create custom tools
> +@end itemize")
> +    (license license:gpl3)))

The rest looks fine.  It'd be nice to get the test suite passing.

Thanks,

Maxim
Sughosha Sept. 28, 2022, 5:35 p.m. UTC | #2
Hi,

Thanks for reviewing. The problem is only that while validating the appstream it requires connecting to internet, but in Guix packaging works offline. Otherwise if built outside Guix, then it passes the test.

And, I will correct and send another patch file.

Sughosha

Gesendet von Proton Mail für Mobilgeräte

-------- Original-Nachricht --------
Am 28. Sept. 2022, 7:26 PM, schrieb Maxim Cournoyer :

> Hello, Sughosha  writes: > From: Sughosha  > > * gnu/packages/text-editors.scm (textpieces): New variable. [...] > +(define-public textpieces > + (package > + (name "textpieces") > + (version "3.2.0") > + (source (origin > + (method git-fetch) > + (uri (git-reference > + (url "https://github.com/liferooter/textpieces") > + (commit (string-append "v" version)))) > + (sha256 > + (base32 > + "14zq2c7js80m4cq8wpdb3kyz5sw96l8znbz027w8s94gqhm632ff")))) > + (arguments > + `(#:tests? #f ;fails to validate appstream file Is this a known issue upstream? If so, it should be linked with a full sentence, for example: "The test suite fails validating the appstream file (see: https://www.upstream-issue-url)." > + #:glib-or-gtk? #t)) > + (build-system meson-build-system) > + (native-inputs (list pkg-config > + vala > + desktop-file-utils > + appstream-glib > + gettext-minimal > + `(,glib "bin") > + blueprint-compiler > + `(,gtk "bin"))) > + (inputs (list gtk > + libadwaita > + gtksourceview > + json-glib > + libgee > + python > + python-pygobject > + python-pyyaml)) Please sort the dependencies in lexicographical order. > + (home-page "https://github.com/liferooter/textpieces") > + (synopsis "Quick text processor") > + (description > + "Text Pieces tool for quick text transformations such as checksums, ^ is a tool > +encoding, decoding and so on. ^, etc. > +The basic features of Text Pieces are: > +@itemize > +@item Base64 encoding and decoding > +@item SHA-1, SHA-2 and MD5 checksums > +@item Prettify and minify JSON > +@item Covert JSON to YAML and vice versa > +@item Count lines, symbols and words > +@item Escape and unescape string, URL and HTML > +@item Remove leading and trailing whitespaces > +@item Sort and reverse sort lines > +@item Reverse lines and whole text > +@item You can write your own scripts and create custom tools > +@end itemize") > + (license license:gpl3))) The rest looks fine. It'd be nice to get the test suite passing. Thanks, Maxim
Christopher Baines Oct. 16, 2022, 6:27 p.m. UTC | #3
Sughosha via Guix-patches via <guix-patches@gnu.org> writes:

> Thanks for reviewing. The problem is only that while validating the
> appstream it requires connecting to internet, but in Guix packaging
> works offline. Otherwise if built outside Guix, then it passes the
> test.
>
> And, I will correct and send another patch file.

Hi both,

I got a bit confused and I thought an updated patch was attached to this
reply, and went ahead and pushed as
fc68b97db12b34dec558fde73d651aa0d3bbd446, with a couple of tweaks.

I did miss changing some of the things that Maxim suggested though. If
you can Sughosha, please do send a patch to make the relevant changes,
otherwise I can try and clean things up.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 0c30a705b9..8852bbf067 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -45,6 +45,7 @@  (define-module (gnu packages text-editors)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system glib-or-gtk)
+  #:use-module (guix build-system meson)
   #:use-module (guix build-system python)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages)
@@ -62,6 +63,7 @@  (define-module (gnu packages text-editors)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages haskell-xyz)
@@ -1260,3 +1262,56 @@  (define-public mle
 splitting, multiple cursors, and integration with various shell
 commands.")
     (license license:asl2.0)))
+
+(define-public textpieces
+  (package
+    (name "textpieces")
+    (version "3.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/liferooter/textpieces")
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32
+                "14zq2c7js80m4cq8wpdb3kyz5sw96l8znbz027w8s94gqhm632ff"))))
+    (arguments
+     `(#:tests? #f ;fails to validate appstream file
+       #:glib-or-gtk? #t))
+    (build-system meson-build-system)
+    (native-inputs (list pkg-config
+                         vala
+                         desktop-file-utils
+                         appstream-glib
+                         gettext-minimal
+                         `(,glib "bin")
+                         blueprint-compiler
+                         `(,gtk "bin")))
+    (inputs (list gtk
+                  libadwaita
+                  gtksourceview
+                  json-glib
+                  libgee
+                  python
+                  python-pygobject
+                  python-pyyaml))
+    (home-page "https://github.com/liferooter/textpieces")
+    (synopsis "Quick text processor")
+    (description
+     "Text Pieces tool for quick text transformations such as checksums,
+encoding, decoding and so on.
+
+The basic features of Text Pieces are:
+@itemize
+@item Base64 encoding and decoding
+@item SHA-1, SHA-2 and MD5 checksums
+@item Prettify and minify JSON
+@item Covert JSON to YAML and vice versa
+@item Count lines, symbols and words
+@item Escape and unescape string, URL and HTML
+@item Remove leading and trailing whitespaces
+@item Sort and reverse sort lines
+@item Reverse lines and whole text
+@item You can write your own scripts and create custom tools
+@end itemize")
+    (license license:gpl3)))