diff mbox series

[bug#63065,v2,03/16] gnu: Add function2.

Message ID zgMER_oEVpxnO_jBXaYIjv91T1eTbNwmrHKNk5eqZrwcV4RthIPUMyVrxNEbznR95Y_DImKCsXC9JBLev5UWK7qYujVHN0-eFtRyKp5haZ4=@proton.me
State New
Headers show
Series None | expand

Commit Message

Sughosha June 29, 2023, 10:18 a.m. UTC
* gnu/packages/cpp.scm (function2): New variable.
---
 gnu/packages/cpp.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 40640202f9..46a7b61021 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2118,6 +2118,39 @@  (define-public bitsery
     (home-page "https://github.com/fraillt/bitsery")
     (license license:expat)))
 
+(define-public function2
+  (package
+    (name "function2")
+    (version "4.2.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Naios/function2")
+                    (commit version)
+                    ;; Tests require to compile googletest with custom
+                    ;; features.
+                    (recursive? #t)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1xayd46d19k2b4q8413kp0453wc2k4jbrq7fq9rilcgmdk9m5bmc"))))
+    (build-system cmake-build-system)
+    ;; The test size_match_layout fails on i586/i686. For more info:
+    ;; https://github.com/Naios/function2/issues/57
+    (arguments
+     (list #:tests? #f))
+    (synopsis "Improved implementations of std::function")
+    (description "This package provides the following implementations of
+std::function:
+@itemize
+@item copyable fu2::function
+@item move-only fu2::unique_function (capable of holding move only types)
+@item non-owning fu2::function_view (capable of referencing callables in a non
+owning way)
+@end itemize")
+    (home-page "https://naios.github.io/function2/")
+    (license license:boost1.0)))
+
 (define-public cpp-mustache
   (package
     (name "cpp-mustache")