From 14b23d3ae7ffe5192a96a3e92e58175bd67e3497 Mon Sep 17 00:00:00 2001
From: Luis Felipe <luis.felipe.la@protonmail.com>
Date: Sat, 23 Apr 2022 14:14:43 -0500
Subject: [PATCH] gnu: gfeeds: Make it start.
This change patches the version of WebKit required by the program to a
version available in Guix, so that the program actually starts.
* gnu/packages/syndication.scm (gfeeds)[arguments]: Require WebKit2
4.1 instead of 4.0, which is not available.
---
gnu/packages/syndication.scm | 6 ++++++
1 file changed, 6 insertions(+)
@@ -3,6 +3,7 @@
;;; Copyright © 2018, 2019, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2022 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -537,6 +538,11 @@ (define-public gfeeds
(substitute* "gfeeds/confManager.py"
(("mpv") (search-input-file inputs "/bin/mpv")))
#t))
+ (add-after 'unpack 'patch-webkit2-version
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "bin/gfeeds.in"
+ (("gi\\.require_version\\('WebKit2', '4\\.0'\\)")
+ "gi.require_version('WebKit2', '4.1')"))))
(add-after 'install 'wrap-gfeeds
(lambda* (#:key outputs #:allow-other-keys)
(wrap-program (string-append
--
2.35.1