diff mbox series

[bug#41297] gnu: openctm: Correct inputs vs native-inputs

Message ID zNBmy4CTl_peMQ-9S7lElZFjofYW1DVtSTtDOyq9Rk7zWkYaJxkZYJmN7FUV0sqdkrWugMehtMlO-gwglkTXx_biL9ZyvdIf1TI-CdNKJ2Q=@elenq.tech
State Accepted
Headers show
Series [bug#41297] gnu: openctm: Correct inputs vs native-inputs | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ekaitz Zarraga May 15, 2020, 10:57 p.m. UTC
From 417f64adc854e5d717351fec68872ed19a9ac3df Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Sat, 16 May 2020 00:49:53 +0200
Subject: [PATCH] gnu: openctm: Correct inputs vs native-inputs

    * gnu/packages/engineering.scm (openctm): Change inputs
---
 gnu/packages/engineering.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

--
2.26.1

Comments

Jonathan Brielmaier May 15, 2020, 11:35 p.m. UTC | #1
On 16.05.20 00:57, Ekaitz Zarraga wrote:
> From 417f64adc854e5d717351fec68872ed19a9ac3df Mon Sep 17 00:00:00 2001
> From: Ekaitz Zarraga <ekaitz@elenq.tech>
> Date: Sat, 16 May 2020 00:49:53 +0200
> Subject: [PATCH] gnu: openctm: Correct inputs vs native-inputs

Please add a dot add the end of sentences.

>     * gnu/packages/engineering.scm (openctm): Change inputs

Maybe rephrase it to: Move pkg-config to native-inputs.

> ---
>  gnu/packages/engineering.scm | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
> index aec692174a..aab414bf0e 100644
> --- a/gnu/packages/engineering.scm
> +++ b/gnu/packages/engineering.scm
> @@ -2557,11 +2557,12 @@ official SDK.")
>            (base32 "01wb70m48xh5gwhv60a5brv4sxl0i0rh038w32cgnlxn5x86s9f1"))))
>        (build-system gnu-build-system)
>        (native-inputs
> +       `(("pkg-config" ,pkg-config)))
> +      (inputs
>         `(("mesa" ,mesa)
>           ("glu" ,glu)
>           ("glut" ,freeglut)
> -         ("gtk" ,gtk+-2)
> -         ("pkg-config" ,pkg-config)))
> +         ("gtk" ,gtk+-2)))
>        (arguments
>         `(#:tests? #f                              ;no tests
>           #:phases
> --

Otherwise it looks good.
Ekaitz Zarraga May 16, 2020, 9:57 a.m. UTC | #2
Hi,

>
> Maybe rephrase it to: Move pkg-config to native-inputs.
>

In fact, the pkg-config is the only one that it's not moved. The change is moving all of the others to inputs.

I really bad at describing what I did. I don't know how to say it short and accurately :D

Thanks!
Jonathan Brielmaier May 16, 2020, 10:06 a.m. UTC | #3
On 16.05.20 11:57, Ekaitz Zarraga wrote:
> Hi,
>
>>
>> Maybe rephrase it to: Move pkg-config to native-inputs.
>>
>
> In fact, the pkg-config is the only one that it's not moved. The change is moving all of the others to inputs.
>
> I really bad at describing what I did. I don't know how to say it short and accurately :D

Ah, so it's the other way round. So move mesa, glu, glut and gtk+-2 to
inputs.
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index aec692174a..aab414bf0e 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2557,11 +2557,12 @@  official SDK.")
           (base32 "01wb70m48xh5gwhv60a5brv4sxl0i0rh038w32cgnlxn5x86s9f1"))))
       (build-system gnu-build-system)
       (native-inputs
+       `(("pkg-config" ,pkg-config)))
+      (inputs
        `(("mesa" ,mesa)
          ("glu" ,glu)
          ("glut" ,freeglut)
-         ("gtk" ,gtk+-2)
-         ("pkg-config" ,pkg-config)))
+         ("gtk" ,gtk+-2)))
       (arguments
        `(#:tests? #f                              ;no tests
          #:phases