diff mbox series

[bug#41181] adds emacs-interleave

Message ID zF-leJAkclvDcMy9CGz-YtZBjCrIbcwPw215S7lniHkKR5LoA16vFNKtWpVNQ4xt1i9p-vz0uix1p14zS0EY6hbounKmwBbWpjp16hNJ0gs=@protonmail.com
State Accepted
Headers show
Series [bug#41181] adds emacs-interleave | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

guix--- via Guix-patches via May 22, 2020, 1:42 a.m. UTC
Hello Nicolas,

Thanks for the insight.  Attached is a patch with the suggestions from the previous email.

-Ryan


Sent with ProtonMail Secure Email.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Sunday, May 17, 2020 7:00 PM, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

&gt; Hello,
&gt;
&gt; rdes rdes@protonmail.com writes:
&gt;
&gt; &gt; Subject: [PATCH] * gnu/packages/emacs-xyz.scm (emacs-interleave): New
&gt; &gt; variable.
&gt;
&gt; Thank you for the updated patch. Some comments follow.
&gt;
&gt; &gt; +(define-public emacs-interleave
&gt; &gt;
&gt; &gt; -   (package
&gt; &gt; -   (name "emacs-interleave")
&gt; &gt; -   (version "1.4.0")
&gt; &gt; -   (source
&gt; &gt; -       (origin
&gt; &gt;
&gt; &gt;
&gt; &gt; -         (method git-fetch)
&gt; &gt;
&gt; &gt;
&gt; &gt; -         (uri
&gt; &gt;
&gt; &gt;
&gt; &gt; -          (git-reference
&gt; &gt;
&gt; &gt;
&gt; &gt; -           (url "https://github.com/rudolfochrist/interleave")
&gt; &gt;
&gt; &gt;
&gt; &gt; -           (commit (string-append "interleave-" version))))
&gt; &gt;
&gt; &gt;
&gt; &gt; -         (file-name (git-file-name name version))
&gt; &gt;
&gt; &gt;
&gt; &gt; -         (sha256
&gt; &gt;
&gt; &gt;
&gt; &gt; -          (base32
&gt; &gt;
&gt; &gt;
&gt; &gt; -           "0l5b681mrpk12lx5c16m7kc13p29z6zismwg1llsjg7cdmrmsrcb"))))
&gt; &gt;
&gt; &gt;
&gt;
&gt; Could you move the hash on the line above?
&gt;
&gt; &gt; -   (build-system emacs-build-system)
&gt; &gt; -   (home-page
&gt; &gt; -       "https://github.com/rudolfochrist/interleave")
&gt; &gt;
&gt; &gt;
&gt;
&gt; Could you move the URI on the line above, too?
&gt;
&gt; &gt; -   (synopsis
&gt; &gt; -       "A minor mode that presents a document buffer next to an orgmode buffer")
&gt; &gt;
&gt; &gt;
&gt;
&gt; A synopsis does not start with "A". You may want to use "guix lint" to
&gt; spot this.
&gt;
&gt; You might use the summary from the home page:
&gt;
&gt; (synopsis "Emacs minor mode to interleave notes and text books")
&gt;
&gt; &gt; -   (description
&gt; &gt; -       "Interleave is a minor mode that presents a document viewer side
&gt; &gt;
&gt; &gt;
&gt; &gt;
&gt; &gt; +by side to an orgmode buffer with your notes relevant to the current
&gt; &gt; page.")
&gt;
&gt; "orgmode buffer" -&gt; "an Org buffer"
&gt;
&gt; Could you send an updated patch and merge this with the copyright line
&gt; you sent?
&gt;
&gt; Regards,
&gt;
&gt; ---------------------------------------------------------------------------------------------
&gt;
&gt; Nicolas Goaziou

</mail@nicolasgoaziou.fr>

Comments

Nicolas Goaziou May 25, 2020, 11:43 a.m. UTC | #1
Hello,

rdes <rdes@protonmail.com> writes:

> From: Ryan Desfosses <ryan@desfo.org>
> Date: Fri, 15 May 2020 16:53:02 -0400
> Subject: [PATCH] * gnu/packages/emacs-xyz.scm (emacs-interleave): New
>  variable.

I fixed the commit message and applied your patch. Thank you.

Regards,
diff mbox series

Patch

From 8997cb28bc694b0a614d691db592ccfc1f85b790 Mon Sep 17 00:00:00 2001
From: Ryan Desfosses <ryan@desfo.org>
Date: Fri, 15 May 2020 16:53:02 -0400
Subject: [PATCH] * gnu/packages/emacs-xyz.scm (emacs-interleave): New
 variable.

* gnu/packages/emacs-xyz.scm: Add copyright.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 45ccced99e..1a25547508 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -70,6 +70,7 @@ 
 ;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 pinoaffe <pinoaffe@airmail.cc>
+;;; Copyright © 2020 Ryan Desfosses <rdes@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6052,6 +6053,28 @@  the Hydra very seamless; it's like a minor mode that disables itself
 automatically.")
     (license license:gpl3+)))
 
+(define-public emacs-interleave
+  (package
+    (name "emacs-interleave")
+    (version "1.4.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/rudolfochrist/interleave")
+         (commit (string-append "interleave-" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0l5b681mrpk12lx5c16m7kc13p29z6zismwg1llsjg7cdmrmsrcb"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/rudolfochrist/interleave")
+    (synopsis "Emacs minor mode to interleave notes and text books")
+    (description
+     "Interleave is a minor mode that presents a document viewer side
+by side to an Org buffer with your notes relevant to the current page.")
+    (license license:gpl3+)))
+
 (define-public emacs-ivy
   (package
     (name "emacs-ivy")
-- 
2.26.2