diff mbox series

[bug#53372] gnu: libratbag: Add python to native inputs.

Message ID z6-larPP8HJdE5HSz90-XXqN5ndWYIQC0UOzliB3obnQpcFVewJoRklFKaz1jz4G4nYwihGCULdFvnE3vC2-xPqJXfLnKMaCCvyHgD304CE=@protonmail.com
State Accepted
Headers show
Series [bug#53372] gnu: libratbag: Add python to native inputs. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

John Kehayias Jan. 19, 2022, 7:09 p.m. UTC
This fixes the tests failing due to change in Meson not propagating python. Same as other fixes, e.g. 65b2b142358f8d38cf993855fcc4ce0b9ef107eb

Comments

Mathieu Othacehe Jan. 20, 2022, 1:23 p.m. UTC | #1
> Since commit 5d20d7e1369fc7d93de19c0bd219937d697ceae6, meson no longer
> propagates Python.

Closing, thanks!

Mathieu
diff mbox series

Patch

From 13dedd496eb6f7e944348f4c76831e8cec27af41 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Wed, 19 Jan 2022 14:07:13 -0500
Subject: [PATCH] gnu: libratbag: Add python to native inputs.

Since commit 5d20d7e1369fc7d93de19c0bd219937d697ceae6, meson no longer
propagates Python.

* gnu/packages/gnome.scm (libratbag)[native-inputs]: Add python.
---
 gnu/packages/gnome.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ecec55942d..5f09c17112 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12055,7 +12055,7 @@  (define-public libratbag
                  python-wrap)
                #t))))))
     (native-inputs
-     (list check pkg-config swig valgrind))
+     (list check pkg-config python swig valgrind))
     (inputs
      `(("glib" ,glib)
        ("json-glib" ,json-glib)
-- 
2.34.0