diff mbox series

[bug#51193] Subject: [PATCH 1/4] gnu: Add rust-cpuprofiler-0.0.4.

Message ID z5j7TKb8VrWU9lXZ7vQfuQqPDC8KK9CJECAEKOu76TomEMrzKlXqeGIxxazbhfty5UwM3IPIaIspta3OggHKqYX38hG64suNvbhyehsKGYI=@protonmail.com
State Accepted
Headers show
Series [bug#51193] Subject: [PATCH 1/4] gnu: Add rust-cpuprofiler-0.0.4. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Oct. 13, 2021, 10:07 p.m. UTC
Hi,

these patches add tool similar to i3status, polybar, etc which is used in WM like i3 or sway to display the contents of the bars.

This one is written in Rust and can be used under Wayland and X11. Therefore I placed it into the rust-apps.scm rather than wm.scm. But I'm open to critical review :-)

Petr

--8<---------------cut here---------------start------------->8---
* gnu/packages/crates-io.scm (rust-cpuprofiler-0.0.4): New variable.

--
2.33.0

Comments

Efraim Flashner Nov. 8, 2021, 8:55 a.m. UTC | #1
I pushed these patches and forgot to close the bug. Patches pushed!
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 089b9f456c..5fb7bd9e69 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -46,6 +46,7 @@ 
   #:use-module (gnu packages admin)
   #:use-module (gnu packages cmake)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages cpp)
   #:use-module (gnu packages crates-graphics)
   #:use-module (gnu packages crates-gtk)
   #:use-module (gnu packages crypto)
@@ -10461,6 +10462,32 @@  to the @code{is_x86_feature_detected!} macro.")
 to @code{is_x86_feature_detected}.")
     (license (list license:expat license:asl2.0))))

+(define-public rust-cpuprofiler-0.0.4
+  (package
+    (name "rust-cpuprofiler")
+    (version "0.0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "cpuprofiler" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0az588yyl9r13w4k7xfdh5ckfaq52fwpjry2q2hblazxpjflgy23"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-error-chain" ,rust-error-chain-0.12)
+        ("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-pkg-config" ,rust-pkg-config-0.3))))
+    (inputs `(("gperftools" ,gperftools)))
+    (home-page
+     "https://github.com/AtheMathmo/cpuprofiler")
+    (synopsis "Bindings to google's cpu profiler")
+    (description "Bindings to google's cpu profiler")
+    (license license:bsd-2)))
+
 (define-public rust-crates-index-0.13
   (package
     (name "rust-crates-index")