diff mbox series

[bug#37284] added gnu/packages/fmit.scm (Free Musical Instrument Tuner)

Message ID z0fzDYR5B8kf6z0zwtMeoxvnsVBa2Hw-eur3Uth26a3Tp4AD2bc4LBtkm2I7obhspf87g0O_d6g7XML2BcnbdB51TRD_-II1e3gETzI00z0=@protonmail.com
State Accepted
Headers show
Series [bug#37284] added gnu/packages/fmit.scm (Free Musical Instrument Tuner) | expand

Commit Message

ashish.is--- via Guix-patches" via Sept. 8, 2019, 9:25 a.m. UTC
Yep, looks like I _thought_ I used `git commit -a --amend` but I forgot the -a. *facepalm*
Here is what I actually wanted to send.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Sunday, September 8, 2019 9:17 AM, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

> Hello,
>
> raingloom raingloom@protonmail.com writes:
>
> > Updated again. Is sending it as an attachment fine?
>
> Well, oddly, it seems that your update addressed only one of my
> suggestions. So, I applied your patch with the following changes:
>
> -   fixed the commit message,
> -   added a copyright line,
> -   added the (file-name ...) line,
> -   split the (sha256 ...) line,
> -   re-ordered the inputs,
> -   changed case in synopsis,
> -   fixed typographic mistakes in the description and the licenses
>     comments.
>
>     Let me know if something is wrong, in particular the copyright line,
>     which I add to guess.
>
>     Thank you for your contribution!
>
>     Regards,
>
>     --
>     Nicolas Goaziou
>
diff mbox series

Patch

From 0bbe19a1d37c981f699d4681e237aadc61089c90 Mon Sep 17 00:00:00 2001
From: raingloom <raingloom@protonmail.com>
Date: Mon, 2 Sep 2019 15:44:15 +0200
Subject: [PATCH] * gnu/packages/music.scm (fmit): New variable.

---
 gnu/packages/music.scm | 62 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 62 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index d4aaecc1e2..0e0ead5229 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -22,6 +22,7 @@ 
 ;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
 ;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
 ;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
+;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4483,3 +4484,64 @@  discard bad quality ones.
 controller.")
     (home-page "https://github.com/charlesfleche/lpd8editor")
     (license license:expat)))
+
+(define-public fmit
+  (package
+    (name "fmit")
+    (version "1.2.6")
+    (source (origin
+	      (method git-fetch)
+	      (uri (git-reference
+		    (url "https://github.com/gillesdegottex/fmit/")
+		    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+	      (sha256
+               (base32
+                "03nzkig5mw2rqwhwmg0qvc5cnk9bwh2wp13jh0mdrr935w0587mz"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+	 (delete 'configure)
+	 (add-before 'build 'qmake
+	   (lambda _
+	     (let ((out (assoc-ref %outputs "out")))
+               (invoke "qmake"
+                       "fmit.pro"
+                       (string-append "PREFIX=" out)
+                       (string-append "PREFIXSHORTCUT=" out)
+                       "CONFIG+=acs_qt acs_alsa acs_jack acs_portaudio"))))
+         (add-after 'install 'wrap-executable
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (wrap-program (string-append out "/bin/fmit")
+                 `("QT_PLUGIN_PATH" ":" prefix
+                   ,(map (lambda (label)
+                           (string-append (assoc-ref inputs label)
+                                          "/lib/qt5/plugins"))
+                         '("qtbase" "qtmultimedia" "qtsvg")))
+                 `("QML2_IMPORT_PATH" ":" prefix
+                   ,(map (lambda (label)
+                           (string-append (assoc-ref inputs label)
+                                          "/lib/qt5/qml"))
+                         '("qtmultimedia"))))
+               #t))))))
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("fftw" ,fftw)
+       ("jack" ,jack-1)
+       ("portaudio" ,portaudio)
+       ("qtbase" ,qtbase)
+       ("qtmultimedia" ,qtmultimedia)
+       ("qtsvg" ,qtsvg)))
+    (native-inputs
+     `(("gettext" ,gnu-gettext)
+       ("hicolor-icon-theme" ,hicolor-icon-theme)
+       ("itstool" ,itstool)
+       ("qttools" ,qttools)))
+    (synopsis "Musical instrument tuner")
+    (description "FMIT is a graphical utility for tuning musical instruments,
+with error and volume history, and advanced features.")
+    (home-page "https://gillesdegottex.github.io/fmit/")
+    ;; Most of the code is under GPL2+, but some abstract or helper classes are under LGPL2.1.
+    (license (list license:gpl2+ license:lgpl2.1))))
-- 
2.23.0