diff mbox series

[bug#59791] Add mitmproxy

Message ID yw1DAISr0DutNGQWFNOC5s_7u_27bOvMN8ikKdt3qMinwG8FUAnn3X2LwZFRbu1DI2jaVFk53HlQAUFnM7p8TWJMNEhq7uNWxcBlBGo9eZI=@protonmail.com
State New
Headers show
Series [bug#59791] Add mitmproxy | expand

Commit Message

phodina Dec. 3, 2022, 4:18 a.m. UTC
Hello,

this patch series adds man-in-the-middle proxy.

----
Petr
diff mbox series

Patch

From e9dfd4a0e194dcf59bd5b387bb5d510b44583cdf Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Fri, 2 Dec 2022 22:29:59 +0100
Subject: [PATCH 5/7] gnu: python-sortedcontainers: Update to 2.3.0. Remove
 input labels.

* gnu/packages/python-xyz.scm (python-sortedcontainers): Update to 2.3.0.
Remove input labels.

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ffd3d16bb5..41fecbf477 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23737,24 +23737,24 @@  (define-public python-sortedcollections
 (define-public python-sortedcontainers
   (package
     (name "python-sortedcontainers")
-    (version "2.1.0")
+    (version "2.3.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "sortedcontainers" version))
        (sha256
         (base32
-         "0fm0w5id2yhqld95hg2m636vjgkz377rvgdfqaxc25vbylr9lklp"))))
+         "188h9d3f9qc6ixk1lz6g1656aq59i5y5jxb7q5vxcq6ga1v97k2r"))))
     (build-system python-build-system)
     (arguments
      ;; FIXME: Tests require many extra dependencies, and would introduce
      ;; a circular dependency on hypothesis, which uses this package.
      '(#:tests? #f))
     (propagated-inputs
-     `(("python-appdirs" ,python-appdirs)
-       ("python-distlib" ,python-distlib)
-       ("python-filelock" ,python-filelock)
-       ("python-six" ,python-six-bootstrap)))
+     (list python-appdirs
+           python-distlib
+           python-filelock
+           python-six-bootstrap))
     (home-page "http://www.grantjenks.com/docs/sortedcontainers/")
     (synopsis "Sorted List, Sorted Dict, Sorted Set")
     (description
-- 
2.38.1