diff mbox series

[bug#64552,v2] gnu: Add dhex.

Message ID yvjumkfvh7nhldpwfij26xadfgdcbadmnq2iy4ry26havq53j4@al6skq7qv5c3
State New
Headers show
Series [bug#64552,v2] gnu: Add dhex. | expand

Commit Message

flabbergasted Sept. 9, 2023, 10 a.m. UTC
* gnu/packages/hexedit.scm (dhex): New variable.
---
 gnu/packages/hexedit.scm | 43 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/hexedit.scm b/gnu/packages/hexedit.scm
index 79c14a2..7d3f7d0 100644
--- a/gnu/packages/hexedit.scm
+++ b/gnu/packages/hexedit.scm
@@ -29,6 +29,8 @@  (define-module (gnu packages hexedit)
   #:use-module (gnu packages ncurses)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module (guix gexp)
+  #:use-module (guix utils)
   #:use-module (guix build-system gnu))
 
 (define-public hexedit
@@ -69,6 +71,47 @@  (define-public hexedit
     (home-page "http://rigaux.org/hexedit.html")
     (license license:gpl2+)))
 
+(define-public dhex
+  (package
+    (name "dhex")
+    (version "0.69")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://www.dettus.net/dhex/" name "_"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "06y4lrp29f2fh303ijk1xhspa1d4x4dm6hnyw3dd8szi3k6hnwsj"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:tests? #f ;no tests provided
+      #:make-flags
+      #~(list (string-append "CC=" #$(cc-for-target)))
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure) ;no configure script
+          (replace 'install ;multiple issues with provided 'make install'
+            (lambda _
+              (let ((bin (string-append #$output "/bin"))
+                    (man1 (string-append #$output
+                                         "/share/man/man1"))
+                    (man5 (string-append #$output
+                                         "/share/man/man5")))
+                (install-file "dhex" bin)
+                (install-file "dhex.1" man1)
+                (install-file "dhexrc.5" man5)
+                (install-file "dhex_markers.5" man5)
+                (install-file "dhex_searchlog.5" man5)))))))
+    (inputs (list ncurses))
+    (home-page "https://www.dettus.net/dhex/")
+    (synopsis "View, edit, and diff files in hexadecimal")
+    (description
+     "Dhex is hex editor which includes a diff mode, which can be used to
+easily and conveniently compare two binary files.  It is based on ncurses
+and is themeable.")
+    (license license:gpl2+)))
+
 (define-public ht
   (package
     (name "ht")