diff mbox series

[bug#50590,5/8] gnu: Add chicken-regex.

Message ID yguy27zc4os.fsf@netpanic.org
State Accepted
Headers show
Series Add CHICKEN Eggs | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Streit Sept. 14, 2021, 6 p.m. UTC
* gnu/packages/chicken.scm (chicken-regex): New variable.
---
 gnu/packages/chicken.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

--
2.33.0
diff mbox series

Patch

diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index e47bced5aa..0ca5fff02e 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -368,3 +368,25 @@  project")
 SSAX/SXML Sourceforge project.  It incorporates one main module, and an
 auxiliary one.")
     (license license:public-domain)))
+
+(define-public chicken-regex
+  (package
+    (name "chicken-regex")
+    (version "2.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (egg-uri "regex" version))
+        (sha256
+          (base32
+            "1hxkva5jvk08wnj3x4lnyxhhyr5vkbs7q99qzpnwmfphbrzmmqzr"))))
+    (build-system chicken-build-system)
+    (arguments `(#:egg-name "regex"))
+    (home-page "https://wiki.call-cc.org/egg/regex")
+    (synopsis "Compatibility library for old regular expression API")
+    (description "This extension provides the regular expression API that used
+to be available in CHICKEN releases before version 4.6.2.  It is a thin wrapper
+around the functionality provided by
+@uref{http://wiki.call-cc.org/man/5/Module%20(chicken%20irregex), irregex} and
+is mostly intended to keep old code working.")
+    (license license:bsd-3)))