diff mbox series

[bug#48787] gnu: redis: Update to 6.2.4 [security fixes].

Message ID ygulf7t4132.fsf@netpanic.org
State Accepted
Headers show
Series [bug#48787] gnu: redis: Update to 6.2.4 [security fixes]. | expand

Commit Message

Simon Streit June 1, 2021, 11:28 p.m. UTC
Hi!

Please find attached a patch that updates redis to the current
version 6.2.4.

Please note, that I disabled a test ‘(("integration/failover") "")’,
since it fails.  But since other tests have been disabled like wise, I
hope it is Okay to leave this one off too?

This may well not be a good excuse though.  Here's the error that
happens while leaving it switched on:
--8<---------------cut here---------------start------------->8---
*** [err]: failover to a replica with force works in tests/integration/failover.tcl
Expected 'e561a2488904ba006e3dac0f23f34450552e9dd7' to be equal to 'baafeb65ba165b88bab00215bc2524c22b0ddf6d' (context: type proc line 3 cmd {assert_equal [$n2 debug digest] [$n3 debug digest]} proc ::assert_digests_match level 2)
*** [err]: failover with timeout aborts if replica never catches up in tests/integration/failover.tcl
Expected '357f82255aec8021475fd5b806c2793665584f2e' to be equal to '282f15609b9a05d607e3d0c3d7ef5fc8319836eb' (context: type proc line 3 cmd {assert_equal [$n2 debug digest] [$n3 debug digest]} proc ::assert_digests_match level 2)
Cleanup: may take some time... OK
make[1]: *** [Makefile:383: test] Error 1
make[1]: Leaving directory '/tmp/guix-build-redis-6.2.4.drv-0/redis-6.2.4/src'
make: *** [Makefile:6: check] Error 2
--8<---------------cut here---------------end--------------->8---
Greetings
Simon

Comments

Leo Famulari June 2, 2021, 5:22 a.m. UTC | #1
On Wed, Jun 02, 2021 at 01:28:01AM +0200, Simon Streit wrote:
> Please find attached a patch that updates redis to the current
> version 6.2.4.

Thanks! Pushed as 841edfa49119c63eade4930751ac4ff5c012bfe5
 
> Please note, that I disabled a test ‘(("integration/failover") "")’,
> since it fails.  But since other tests have been disabled like wise, I
> hope it is Okay to leave this one off too?

Okay. Can you report this test failure upstream?

https://redis.io/community
diff mbox series

Patch

From b5584018ad8464d11b623e15ac652b11a13282d1 Mon Sep 17 00:00:00 2001
From: Simon Streit <simon@netpanic.org>
Date: Wed, 2 Jun 2021 01:11:31 +0200
Subject: [PATCH] gnu: redis: Update to 6.2.4 [security fixes].

Fixes CVE-2021-29477.

* gnu/packages/databases.scm: Update to 6.2.4.
---
 gnu/packages/databases.scm | 16 +++++++++-------
 1 file changed, 9 insertions(+), 7 deletions(-)

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index cead8c0e5a..cd760ee5ef 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -51,6 +51,7 @@ 
 ;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
 ;;; Copyright © 2021 Pjotr Prins <pjotr.guix@thebird.nl>
 ;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
+;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2135,14 +2136,14 @@  similar to BerkeleyDB, LevelDB, etc.")
 (define-public redis
   (package
     (name "redis")
-    (version "6.0.11")
+    (version "6.2.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://download.redis.io/releases/redis-"
                                   version".tar.gz"))
               (sha256
                (base32
-                "0prwqap452m581nyc3cz642d1z3x9nd81896hlqdm3z8238z49y9"))
+                "0vp1d9mlfsppry3nsj9f7bmh9wjgsy3jggp24sac1hhgl43c8cms"))
               (modules '((guix build utils)))
               (snippet
                ;; Delete bundled jemalloc, as the package will use the libc one
@@ -2150,8 +2151,8 @@  similar to BerkeleyDB, LevelDB, etc.")
                        #t))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("procps" ,procps) ; for tests
-       ("tcl" ,tcl)))     ; for tests
+     `(("procps" ,procps)               ; for tests
+       ("tcl" ,tcl)))                   ; for tests
     (arguments
      '(#:phases
        (modify-phases %standard-phases
@@ -2168,9 +2169,10 @@  similar to BerkeleyDB, LevelDB, etc.")
            (lambda _
              ;; Disable failing tests
              (substitute* "tests/test_helper.tcl"
-               (("    integration/replication[^-]") "")
-               (("    integration/replication-4") "")
-               (("    integration/replication-psync") ""))
+               (("integration/failover") "")
+               (("integration/replication-4") "")
+               (("integration/replication-psync") "")
+               (("integration/replication[^-]") ""))
              #t)))
        #:make-flags `("CC=gcc"
                       "MALLOC=libc"
-- 
2.31.1