diff mbox series

[bug#49619,v3,2/2] gnu: Add python-pirate-get.

Message ID ydYY7B1n1EvbMlgcAX7iB7Cf1pJxMP1J7vb8zcZK9AYiIHG3tfmmJwBGyXidfCddw_tDBsH_8jTmqcoZLgWlaUYP_P3BsnkKskSd4FsB198=@protonmail.com
State New
Headers show
Series None | expand

Commit Message

phodina Sept. 18, 2021, 12:45 p.m. UTC
* gnu/packages/python-xyz.scm (python-pirate-get): New variable.

--
2.32.0

Comments

phodina Nov. 8, 2021, 4:52 p.m. UTC | #1
Hi Sarah,

is there still something missing for upstreaming?

--
Kind Regards
Petr
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c4fb6edd40..6dcef95f1e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1817,6 +1817,33 @@  helpers.")
       displaying tabular data in a visually appealing ASCII table format.")
     (license license:bsd-3)))

+(define-public python-pirate-get
+  (package
+    (name "python-pirate-get")
+    (version "0.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pirate-get" version))
+       (sha256
+        (base32
+         "07s5ss9dxccx1mip7pyga1fagywkqchxmzz55ng47ac9053ffxkq"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-colorama" ,python-colorama)
+       ("python-pyperclip" ,python-pyperclip)
+       ("python-veryprettytable"
+        ,python-veryprettytable)))
+    (home-page
+     "https://github.com/vikstrous/pirate-get")
+    (synopsis
+     "Command line interface for The Pirate Bay")
+    (description
+     "@code{pirate-get} is a convenient command line tool (inspired by APT)
+to speed up your trip to the Pirate Bay and get your completely legal
+torrents more quickly.")
+    (license license:gpl3)))
+
 (define-public python2-humanfriendly
   (let ((base (package-with-python2
                 (strip-python2-variant python-humanfriendly))))