diff mbox series

[bug#51774] gnu: Add font-source-code-pro.

Message ID yaiXSsoCVrMLglAyuuVFr8pFMnywqiYWZObBrjY-CIRWOHGVgCjkXe3BmjXpDFbBzYzuBbpBYu9WSbCgUKGMqLUEv4zPPRgSHPHdz74ayRs=@protonmail.com
State Accepted
Headers show
Series [bug#51774] gnu: Add font-source-code-pro. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Nov. 11, 2021, 7:22 p.m. UTC
* gnu/packages/fonts.scm (font-source-code-pro): New variable.

--
2.33.0

Comments

Liliana Marie Prikler Nov. 15, 2021, 7:56 p.m. UTC | #1
Hi,

Am Donnerstag, den 11.11.2021, 19:22 +0000 schrieb phodina:
> * gnu/packages/fonts.scm (font-source-code-pro): New variable.
> 
> diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
> index 3f36a71bdd..9ac7e9e127 100644
> --- a/gnu/packages/fonts.scm
> +++ b/gnu/packages/fonts.scm
> @@ -1470,6 +1470,26 @@ (define-public font-sarasa-gothic
>       "Sarasa Gothic is a programming font based on Iosevka and
> Source Han Sans,
>  most CJK characters are same height, and double width as ASCII
> characters.")))
> 
> +(define-public font-source-code-pro
> +  (package
> +    (name "font-source-code-pro")
> +    (version "2.038")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "
> https://github.com/adobe-fonts/source-code-pro")
> +                    (commit (string-append version "R-ro/1.058R-
> it/1.018R-VAR"))))
Am I allowed to ask WTF this versioning scheme is?  Should we just pin
a hash instead?
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "00h4v3rmxyyaxni6nywacxvjnji2g2pi0b4js1yx0g67fvrv2ga
> g"))))
> +    (build-system font-build-system)
> +    (synopsis "Font for coding environments")
> +    (description "Font Source Code Pro is sedigned as a companion to
> Source
> +Sans.")
This scrediption is not very scrediptive ;)  Jokes aside, I'd add "[It]
preserves the design features and vertical proportions of Source Sans,
but alters the glyph widths so that they are uniform across all glyphs
and weights." so that Adobe bois know what they're getting.
> +    (home-page "https://fonts.google.com/specimen/Source+Code+Pro")
I'm not sure whether linking to Google fonts of all places is good
praxis.  Might want to link to Github instead.  FWIW the repo
advertises this: https://adobe-fonts.github.io/source-code-pro/

Cheers
phodina Nov. 15, 2021, 10:12 p.m. UTC | #2
Hi Liliana,


> > https://github.com/adobe-fonts/source-code-pro")
> >
> > -                      (commit (string-append version "R-ro/1.058R-
> >
> >
> >
> > it/1.018R-VAR"))))
>
> Am I allowed to ask WTF this versioning scheme is? Should we just pin
>
> a hash instead?

Hilarious, right? I agree that a hash commit would be better suited here.

>
> > -                (file-name (git-file-name name version))
> >
> >
> > -                (sha256
> >
> >
> > -                 (base32
> >
> >
> > -                  "00h4v3rmxyyaxni6nywacxvjnji2g2pi0b4js1yx0g67fvrv2ga
> >
> >
> >
> > g"))))
> >
> > -   (build-system font-build-system)
> > -   (synopsis "Font for coding environments")
> > -   (description "Font Source Code Pro is sedigned as a companion to
> >
> >     Source
> >
> >     +Sans.")
>
> This scrediption is not very scrediptive ;) Jokes aside, I'd add "[It]
>
> preserves the design features and vertical proportions of Source Sans,
>
> but alters the glyph widths so that they are uniform across all glyphs
>
> and weights." so that Adobe bois know what they're getting.
>

Thanks for the tip!

> > -   (home-page "https://fonts.google.com/specimen/Source+Code+Pro")
>
> I'm not sure whether linking to Google fonts of all places is good
>
> praxis. Might want to link to Github instead. FWIW the repo
>
> advertises this: https://adobe-fonts.github.io/source-code-pro/
>
> Cheers

Sure, github might be more prefereble.

PS: Though at the end it comes to which is better: Google vs Microsoft ;-)
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 3f36a71bdd..9ac7e9e127 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1470,6 +1470,26 @@  (define-public font-sarasa-gothic
      "Sarasa Gothic is a programming font based on Iosevka and Source Han Sans,
 most CJK characters are same height, and double width as ASCII characters.")))

+(define-public font-source-code-pro
+  (package
+    (name "font-source-code-pro")
+    (version "2.038")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/adobe-fonts/source-code-pro")
+                    (commit (string-append version "R-ro/1.058R-it/1.018R-VAR"))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "00h4v3rmxyyaxni6nywacxvjnji2g2pi0b4js1yx0g67fvrv2gag"))))
+    (build-system font-build-system)
+    (synopsis "Font for coding environments")
+    (description "Font Source Code Pro is sedigned as a companion to Source
+Sans.")
+    (home-page "https://fonts.google.com/specimen/Source+Code+Pro")
+    (license license:silofl1.1)))
+
 (define-public font-space-grotesk
   (package
     (name "font-space-grotesk")