diff mbox series

[bug#49702,v2] gnu: Add swaylock-effects.

Message ID yDhBv0fW4Gb-ibDazPjqlKWJttFpqg6ITNcjksm7tOci9iPT0fIGve6JlWm8AvxUCj_XcPOrpGq4CMSOy0hZAeaWya7XpT12sPb20R65RHo=@protonmail.com
State Accepted
Headers show
Series [bug#49702,v2] gnu: Add swaylock-effects. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina Sept. 18, 2021, 12:14 p.m. UTC
Hi Liliana,

thanks for the inputs!

--8<---------------cut here---------------start------------->8--

* gnu/packages/wm.scm (swaylock-effects): New variable.

--
2.32.0

Comments

Liliana Marie Prikler Sept. 18, 2021, 12:17 p.m. UTC | #1
Hi,

Am Samstag, den 18.09.2021, 12:14 +0000 schrieb phodina:
> Hi Liliana,
> 
> thanks for the inputs!
> 
> --8<---------------cut here---------------start------------->8--
> 
> * gnu/packages/wm.scm (swaylock-effects): New variable.
> 
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 957c5a0d5a..f5f9583fa3 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -83,6 +83,7 @@
>    #:use-module (gnu packages bison)
>    #:use-module (gnu packages build-tools) ;for meson-0.55
>    #:use-module (gnu packages calendar)
> +  #:use-module (gnu packages commencement) ; for gcc>9
>    #:use-module (gnu packages datastructures)
>    #:use-module (gnu packages docbook)
>    #:use-module (gnu packages documentation)
> @@ -1617,6 +1618,30 @@ modules for building a Wayland compositor.")
>      (description "Swaylock is a screen locking utility for Wayland
> compositors.")
>      (license license:expat))) ; MIT license
> 
> +(define-public swaylock-effects
> +  (package (inherit swaylock)
> +           (name "swaylock-effects")
> +           ;; Upstream v1.6-3 released on 16/11/2020
> +           (version "5cb9579faaf5662b111f5722311b701eff1c1d00")
2020 isn't that far in the past.  More importantly, if you do use
random commits, please follow the (git-version) scheme.
> +           (source (origin
> +                     (method git-fetch)
> +                     (uri (git-reference
> +                           (url "
> https://github.com/mortie/swaylock-effects")
> +                           (commit version)))
> +                     (file-name (git-file-name name version))
> +                     (sha256
> +                      (base32
> +                       "036dkhfqgk7g9vbr5pxgrs66h5fz0rwdsc67i1w51aa9
> v01r35ca"))))
> +           ; Requires gcc>=9 see the issue here
> +           ; https://github.com/mortie/swaylock-effects/issues/26
> +           (native-inputs `(("gcc", gcc-9)
> +                            ,@(package-native-inputs swaylock)))
> +           (synopsis "Screen locking utility for Wayland compositors
> with effects")
> +           (description "@code{Swaylock-effects} is a fork of
> swaylock with additional
> +features, such as the ability to take a screenshot as the background
> image,
> +display a clock or apply image manipulation techniques to the
> background image.")
Assuming swaylock-effects is a command (is it?), @command{swaylock-
effects} would be the correct first word here.
> +           (home-page "https://github.com/mortie/swaylock-effects"))
> )
> +
>  (define-public swaybg
>    (package
>      (name "swaybg")
> --
> 2.32.0
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 957c5a0d5a..f5f9583fa3 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -83,6 +83,7 @@ 
   #:use-module (gnu packages bison)
   #:use-module (gnu packages build-tools) ;for meson-0.55
   #:use-module (gnu packages calendar)
+  #:use-module (gnu packages commencement) ; for gcc>9
   #:use-module (gnu packages datastructures)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages documentation)
@@ -1617,6 +1618,30 @@  modules for building a Wayland compositor.")
     (description "Swaylock is a screen locking utility for Wayland compositors.")
     (license license:expat))) ; MIT license

+(define-public swaylock-effects
+  (package (inherit swaylock)
+           (name "swaylock-effects")
+           ;; Upstream v1.6-3 released on 16/11/2020
+           (version "5cb9579faaf5662b111f5722311b701eff1c1d00")
+           (source (origin
+                     (method git-fetch)
+                     (uri (git-reference
+                           (url "https://github.com/mortie/swaylock-effects")
+                           (commit version)))
+                     (file-name (git-file-name name version))
+                     (sha256
+                      (base32
+                       "036dkhfqgk7g9vbr5pxgrs66h5fz0rwdsc67i1w51aa9v01r35ca"))))
+           ; Requires gcc>=9 see the issue here
+           ; https://github.com/mortie/swaylock-effects/issues/26
+           (native-inputs `(("gcc", gcc-9)
+                            ,@(package-native-inputs swaylock)))
+           (synopsis "Screen locking utility for Wayland compositors with effects")
+           (description "@code{Swaylock-effects} is a fork of swaylock with additional
+features, such as the ability to take a screenshot as the background image,
+display a clock or apply image manipulation techniques to the background image.")
+           (home-page "https://github.com/mortie/swaylock-effects")))
+
 (define-public swaybg
   (package
     (name "swaybg")