diff mbox series

[bug#57058,v3] gnu: Add python-lief.

Message ID y76wnb8uxhj.wl-hako@ultrarare.space
State Accepted
Headers show
Series [bug#57058,v3] gnu: Add python-lief. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hilton Chain Aug. 16, 2022, 1:30 p.m. UTC
From c865b31b702d0e5f86faaadcb306cea269ae1109 Mon Sep 17 00:00:00 2001
From: Hilton Chain <hako@ultrarare.space>
Date: Tue, 16 Aug 2022 21:26:33 +0800
Subject: [PATCH v3] gnu: Add python-lief.

* gnu/packages/python-xyz.scm (python-lief): New variable.
---

v2 -> v3: Disable tests.

 gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)


base-commit: ace7b5babe118adb9caf116eb8273f7db6e7f152

Comments

Mathieu Othacehe Aug. 17, 2022, 7:25 a.m. UTC | #1
> * gnu/packages/python-xyz.scm (python-lief): New variable.

Pushed, thanks!

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3259f46881..fbb52a300f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30644,3 +30644,34 @@  (define-public python-misskey
      "This package provides access to Misskey's API.  Misskey is a SNS
 platform using the ActivityPub protocol.")
     (license license:expat)))
+
+(define-public python-lief
+  (package
+    (name "python-lief")
+    (version "0.12.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/lief-project/LIEF")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1xzbh3bxy4rw1yamnx68da1v5s56ay4g081cyamv67256g0qy2i1"))))
+    (build-system python-build-system)
+    (native-inputs (list cmake))
+    (arguments
+     (list #:tests? #f                  ;needs network
+           #:phases #~(modify-phases %standard-phases
+                        (replace 'build
+                          (lambda _
+                            (invoke
+                             "python" "setup.py" "--sdk" "build"
+                             (string-append
+                              "-j" (number->string (parallel-job-count)))))))))
+    (home-page "https://github.com/lief-project/LIEF")
+    (synopsis "Library to instrument executable formats")
+    (description
+     "LIEF is a cross platform library which can parse, modify and abstract ELF,
+PE and MachO formats.")
+    (license license:asl2.0)))