diff mbox series

[bug#57587,v2] gnu: python-apsw: Update to 3.39.2.1.

Message ID y76v8q2nyf4.wl-hako@ultrarare.space
State Accepted
Headers show
Series [bug#57587,v2] gnu: python-apsw: Update to 3.39.2.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hilton Chain Sept. 5, 2022, 6:11 a.m. UTC
From 5bcc29595eefa3632c4ac3ed9e77d8c5a3a7765d Mon Sep 17 00:00:00 2001
From: Hilton Chain <hako@ultrarare.space>
Date: Mon, 5 Sep 2022 10:45:11 +0800
Subject: [PATCH v2] gnu: python-apsw: Update to 3.39.2.1.

* gnu/packages/databases.scm (python-apsw): Update to 3.39.2.1.
[arguments]: Use bundled Makefile.
---
v1 -> v2: Enable parallel compilation.

 gnu/packages/databases.scm | 21 +++++++++++++--------
 1 file changed, 13 insertions(+), 8 deletions(-)


base-commit: d22a5c18517d662516fc93889534367fd3a448f2

Comments

Christopher Baines Sept. 6, 2022, 8:01 a.m. UTC | #1
Hilton Chain via Guix-patches via <guix-patches@gnu.org> writes:

> From 5bcc29595eefa3632c4ac3ed9e77d8c5a3a7765d Mon Sep 17 00:00:00 2001
> From: Hilton Chain <hako@ultrarare.space>
> Date: Mon, 5 Sep 2022 10:45:11 +0800
> Subject: [PATCH v2] gnu: python-apsw: Update to 3.39.2.1.
>
> * gnu/packages/databases.scm (python-apsw): Update to 3.39.2.1.
> [arguments]: Use bundled Makefile.
> ---
> v1 -> v2: Enable parallel compilation.
>
>  gnu/packages/databases.scm | 21 +++++++++++++--------
>  1 file changed, 13 insertions(+), 8 deletions(-)

I think this breaks the calibre package on x86_64-linux, could you take
a look at whether it builds for you with this change?

Thanks,

Chris
Hilton Chain Sept. 6, 2022, 10:46 a.m. UTC | #2
On September 6, 2022 4:01:22 PM GMT+08:00, Christopher Baines <mail@cbaines.net> wrote:

>I think this breaks the calibre package on x86_64-linux, could you take
>a look at whether it builds for you with this change?

Hi Chris,

Yes, there are test errors regarding the 'enableloadextension' attribute, I'll find it out.

Thanks,
Chain
Hilton Chain Sept. 6, 2022, 11:35 a.m. UTC | #3
Just found it's involved by myself in last version... Compressed source actually already had fetching disabled  :‑X
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 7edf0fed2d..70e8c2d6b9 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3568,7 +3568,7 @@  (define-public python-pickleshare
 (define-public python-apsw
   (package
     (name "python-apsw")
-    (version "3.39.2.0")
+    (version "3.39.2.1")
     (source
      (origin
        (method git-fetch)
@@ -3578,20 +3578,25 @@  (define-public python-apsw
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0q7fnk8n3m5mpjzh6xyhj409k8sacdbjsfis98my9c50fdn5sr7y"))))
+         "1pdlmzyn0xnks4iwd99crralpbnli78c28zh000ha8dz4qbr0nsv"))))
     (build-system python-build-system)
     (inputs (list sqlite-next))         ;SQLite 3.39 required.
     (arguments
      (list #:phases
            #~(modify-phases %standard-phases
-               (replace 'build
+               (add-before 'build 'disable-fetch
                  (lambda _
-                   (invoke "python" "setup.py" "build" "--enable-all-extensions"
-                           "--enable=load_extension")))
-               (add-after 'build 'build-test-helper
+                   (substitute* "Makefile"
+                     (("fetch.*--all") ""))))
+               (replace 'build
                  (lambda _
-                   (invoke "gcc" "-fPIC" "-shared" "-o" "./testextension.sqlext"
-                           "-I." "-Isqlite3" "src/testextension.c"))))))
+                   (invoke "make" "-j" (number->string (parallel-job-count))
+                           "build_ext")))
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (invoke "make" "-j" (number->string (parallel-job-count))
+                             "test")))))))
     (home-page "https://github.com/rogerbinns/apsw/")
     (synopsis "Another Python SQLite Wrapper")
     (description