diff mbox series

[bug#57675,v10,8/9] gnu: telegram-desktop: Update to 4.2.0.

Message ID y76sfki8n5i.wl-hako@ultrarare.space
State Accepted
Headers show
Series gnu: telegram-desktop: Update to 4.2.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hilton Chain Sept. 23, 2022, 9:18 a.m. UTC
* gnu/packages/patches/telegram-desktop-allow-disable-libtgvoip.patch: New
file.
* gnu/local.mk (dist_patch_DATA): Add patch.
* gnu/packages/telegram.scm (dispatch-for-telegram-desktop): New variable.
(tgcalls-for-telegram-desktop,codegen-for-telegram-desktop)
(lib-base-for-telegram-desktop,lib-crl-for-telegram-desktop)
(lib-lottie-for-telegram-desktop,lib-qr-for-telegram-desktop)
(lib-rpl-for-telegram-desktop,lib-spellcheck-for-telegram-desktop)
(lib-storage-for-telegram-desktop,lib-tl-for-telegram-desktop)
(lib-ui-for-telegram-desktop,lib-webrtc-for-telegram-desktop)
(lib-webview-for-telegram-desktop,cmake-helpers-for-telegram-desktop): Bump to
source checkout.
(rlottie-for-telegram-desktop): Bump to submodule checkout.
[snippet]: Switch off werror.
[arguments]: Use inherited ones.
(telegram-desktop): Update to 4.2.0.
[patches]: Add telegram-desktop-allow-disable-libtgvoip.patch.
[arguments]<#:configure-flags>: Unbundle rlottie.
<#:phases>: Adjusted accordingly.
[native-inputs]: Add clang-toolchain.
Remove cmake-shared, extra-cmake-modules and qttools-5.
[inputs]: Replace qtbase-5 with qtbase.
Add abseil-cpp-cxxstd17, kcoreaddons, libvpx, qt5compat, wayland, webkitgtk.
Remove catch2, fcitx-qt5, fcitx5-qt, gtk+, hime, kwayland, libdbusmenu-qt,
libtgvoip-for-telegram-desktop, libx11, materialdecoration, nimf and qt5ct.
[propagated-inputs]: Remove dconf.
[license]: Adjusted accordingly.
---
 gnu/local.mk                                  |   1 +
 ...gram-desktop-allow-disable-libtgvoip.patch | 125 ++++++++++
 gnu/packages/telegram.scm                     | 226 +++++++++---------
 3 files changed, 241 insertions(+), 111 deletions(-)
 create mode 100644 gnu/packages/patches/telegram-desktop-allow-disable-libtgvoip.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 10ee65fdd5..e8d0178293 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1871,6 +1871,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/teensy-loader-cli-help.patch		\
   %D%/packages/patches/tensorflow-c-api-fix.patch		\
   %D%/packages/patches/texinfo-5-perl-compat.patch		\
+  %D%/packages/patches/telegram-desktop-allow-disable-libtgvoip.patch   \
   %D%/packages/patches/telegram-purple-adjust-test.patch	\
   %D%/packages/patches/texi2html-document-encoding.patch	\
   %D%/packages/patches/texi2html-i18n.patch			\
diff --git a/gnu/packages/patches/telegram-desktop-allow-disable-libtgvoip.patch b/gnu/packages/patches/telegram-desktop-allow-disable-libtgvoip.patch
new file mode 100644
index 0000000000..3c062cbd9a
--- /dev/null
+++ b/gnu/packages/patches/telegram-desktop-allow-disable-libtgvoip.patch
@@ -0,0 +1,125 @@ 
+From 4d1a8351ee82728912fcf7ad0070049b2910c393 Mon Sep 17 00:00:00 2001
+From: Klemens Nanni <klemens@posteo.de>
+Date: Wed, 2 Mar 2022 01:07:48 +0100
+Subject: [PATCH] Introduce TDESKTOP_DISABLE_LEGACY_TGVOIP
+
+Originally from Alt Linux[0], OpenBSD has so far adapted the removal of
+tgvoip in the official net/tdesktop build.
+
+tgcalls provides everything needed for calls;  audio/video/desktop
+sharing calls have been working fine across different operating systems
+and telegram desktop/mobile versions without problems.
+
+0: http://www.sisyphus.ru/cgi-bin/srpm.pl/Sisyphus/telegram-desktop/getpatch/1
+---
+ Telegram/CMakeLists.txt                   | 6 +++---
+ Telegram/SourceFiles/calls/calls_call.cpp | 6 ++++++
+ Telegram/cmake/lib_tgcalls.cmake          | 4 ++++
+ Telegram/cmake/telegram_options.cmake     | 8 ++++++++
+ 4 files changed, 21 insertions(+), 3 deletions(-)
+
+diff --git a/Telegram/CMakeLists.txt b/Telegram/CMakeLists.txt
+index fb2bf370f..5d9578f2d 100644
+--- a/Telegram/CMakeLists.txt
++++ b/Telegram/CMakeLists.txt
+@@ -28,7 +28,9 @@ get_filename_component(res_loc Resources REALPATH)
+ include(cmake/telegram_options.cmake)
+ include(cmake/lib_ffmpeg.cmake)
+ include(cmake/lib_stripe.cmake)
+-include(cmake/lib_tgvoip.cmake)
++if (NOT TDESKTOP_DISABLE_LEGACY_TGVOIP)
++    include(cmake/lib_tgvoip.cmake)
++endif()
+ include(cmake/lib_tgcalls.cmake)
+ include(cmake/td_export.cmake)
+ include(cmake/td_mtproto.cmake)
+@@ -52,9 +54,7 @@ target_prepare_qrc(Telegram)
+ 
+ target_link_libraries(Telegram
+ PRIVATE
+-    tdesktop::lib_tgcalls_legacy
+     tdesktop::lib_tgcalls
+-    tdesktop::lib_tgvoip
+ 
+     # Order in this list defines the order of include paths in command line.
+     # We need to place desktop-app::external_minizip this early to have its
+diff --git a/Telegram/SourceFiles/calls/calls_call.cpp b/Telegram/SourceFiles/calls/calls_call.cpp
+index 6894d5d90..cd03620e7 100644
+--- a/Telegram/SourceFiles/calls/calls_call.cpp
++++ b/Telegram/SourceFiles/calls/calls_call.cpp
+@@ -39,8 +39,10 @@ class InstanceImpl;
+ class InstanceV2Impl;
+ class InstanceV2ReferenceImpl;
+ class InstanceV2_4_0_0Impl;
++#ifndef TDESKTOP_DISABLE_LEGACY_TGVOIP
+ class InstanceImplLegacy;
+ void SetLegacyGlobalServerConfig(const std::string &serverConfig);
++#endif
+ } // namespace tgcalls
+ 
+ namespace Calls {
+@@ -56,7 +58,9 @@ const auto Register = tgcalls::Register<tgcalls::InstanceImpl>();
+ const auto RegisterV2 = tgcalls::Register<tgcalls::InstanceV2Impl>();
+ const auto RegV2Ref = tgcalls::Register<tgcalls::InstanceV2ReferenceImpl>();
+ const auto RegisterV240 = tgcalls::Register<tgcalls::InstanceV2_4_0_0Impl>();
++#ifndef TDESKTOP_DISABLE_LEGACY_TGVOIP
+ const auto RegisterLegacy = tgcalls::Register<tgcalls::InstanceImplLegacy>();
++#endif
+ 
+ [[nodiscard]] base::flat_set<int64> CollectEndpointIds(
+ 		const QVector<MTPPhoneConnection> &list) {
+@@ -1322,7 +1326,9 @@ Call::~Call() {
+ }
+ 
+ void UpdateConfig(const std::string &data) {
++#ifndef TDESKTOP_DISABLE_LEGACY_TGVOIP
+ 	tgcalls::SetLegacyGlobalServerConfig(data);
++#endif
+ }
+ 
+ } // namespace Calls
+diff --git a/Telegram/cmake/lib_tgcalls.cmake b/Telegram/cmake/lib_tgcalls.cmake
+index 34a5ba418..8a784be2c 100644
+--- a/Telegram/cmake/lib_tgcalls.cmake
++++ b/Telegram/cmake/lib_tgcalls.cmake
+@@ -267,6 +267,10 @@ PRIVATE
+     ${tgcalls_loc}
+ )
+ 
++if (TDESKTOP_DISABLE_LEGACY_TGVOIP)
++    return()
++endif()
++
+ add_library(lib_tgcalls_legacy STATIC)
+ init_target(lib_tgcalls_legacy)
+ 
+diff --git a/Telegram/cmake/telegram_options.cmake b/Telegram/cmake/telegram_options.cmake
+index 1c3c25431..033f2bc95 100644
+--- a/Telegram/cmake/telegram_options.cmake
++++ b/Telegram/cmake/telegram_options.cmake
+@@ -4,7 +4,9 @@
+ # For license and copyright information please follow this link:
+ # https://github.com/telegramdesktop/tdesktop/blob/master/LEGAL
+ 
++option(TDESKTOP_DISABLE_LEGACY_TGVOIP "Disable legacy tgvoip support." OFF)
+ option(TDESKTOP_API_TEST "Use test API credentials." OFF)
++
+ set(TDESKTOP_API_ID "0" CACHE STRING "Provide 'api_id' for the Telegram API access.")
+ set(TDESKTOP_API_HASH "" CACHE STRING "Provide 'api_hash' for the Telegram API access.")
+ 
+@@ -40,6 +42,12 @@ if (TDESKTOP_API_ID STREQUAL "0" OR TDESKTOP_API_HASH STREQUAL "")
+     " ")
+ endif()
+ 
++if (TDESKTOP_DISABLE_LEGACY_TGVOIP)
++    target_compile_definitions(Telegram PRIVATE TDESKTOP_DISABLE_LEGACY_TGVOIP)
++else()
++    target_link_libraries(Telegram PRIVATE tdesktop::lib_tgcalls_legacy tdesktop::lib_tgvoip)
++endif()
++
+ if (DESKTOP_APP_DISABLE_SPELLCHECK)
+     target_compile_definitions(Telegram PRIVATE TDESKTOP_DISABLE_SPELLCHECK)
+ else()
+-- 
+2.37.3
+
diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index 595a649017..397bd43534 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -1,5 +1,6 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
+;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -43,6 +44,7 @@  (define-module (gnu packages telegram)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages libreoffice)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages llvm)
   #:use-module (gnu packages lxqt)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages perl)
@@ -60,6 +62,7 @@  (define-module (gnu packages telegram)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages video)
   #:use-module (gnu packages web)
+  #:use-module (gnu packages webkit)
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xiph)
   #:use-module (gnu packages xorg)
@@ -105,9 +108,24 @@  (define crc32c-for-telegram-desktop
        (base32
         "0cddf8z7v33gfb2k60lkzwa97g20m1v81cnvllm3q9ylpnx8g6f4")))))
 
+(define dispatch-for-telegram-desktop
+  (let ((commit "ecc678d79f38cf63d24b6d16e18f69a9117d8d73")
+        (revision "14"))
+    (origin
+      (method git-fetch)
+      (uri (git-reference
+            (url "https://github.com/apple/swift-corelibs-libdispatch.git")
+            (commit commit)))
+      (file-name
+       (git-file-name
+        "dispatch-for-telegram-desktop" (git-version "5.6" revision commit)))
+      (sha256
+       (base32
+        "0hy4q6x3bgphazmpl3v62995abc9fpi8y7yg9aiblzsqkxmgjmqn")))))
+
 ;; NOTE:
 ;; TDESKTOP_KEEP=(tgcalls)
-;; git checkout v2.9.3
+;; git checkout v4.2.0
 ;; git submodule init
 ;; git submodule deinit --force Telegram/ThirdParty
 ;;
@@ -124,8 +142,8 @@  (define crc32c-for-telegram-desktop
 ;;     | less
 
 (define tgcalls-for-telegram-desktop
-  (let ((commit "81e97fa52e25b7775b62ce07bb653533d81e91b3")
-        (revision "738"))
+  (let ((commit "82c4921045c440b727c38e464f3a0539708423ff")
+        (revision "921"))
     (origin
       (method git-fetch)
       (uri (git-reference
@@ -136,11 +154,11 @@  (define tgcalls-for-telegram-desktop
                   (git-version "0" revision commit)))
       (sha256
        (base32
-        "0fvad87hyxli83xn19mgf8jjrrh6y6iaig14pckpbkg33vf4wqkj")))))
+        "1109r17abh66yz91b65fn2g4ryfybnsr5g6075sjhbah1gccv9mk")))))
 
 (define codegen-for-telegram-desktop
-  (let ((commit "248614b49cd7d5aff69d75a737f2e35b79fbb119")
-        (revision "35"))
+  (let ((commit "8815d7aec9b901191d08445f29e2edd0aeba7b2c")
+        (revision "54"))
     (origin
       (method git-fetch)
       (uri (git-reference
@@ -151,11 +169,11 @@  (define codegen-for-telegram-desktop
                   (git-version "0" revision commit)))
       (sha256
        (base32
-        "00f7g2z6xmkbkrmi3q27hscjl44mg66wf9q0mz3rhy3jaa6cfdrk")))))
+        "1ly958mjk25kfcpa174kvg134p9r751ixi275afj5kr57by9mbq2")))))
 
 (define lib-base-for-telegram-desktop
-  (let ((commit "a23c05c44e4f01dc4428f4d75d4db98c59d313a6")
-        (revision "265"))
+  (let ((commit "cc5550de2766657ced8d0bb4d2db3f050363d3d5")
+        (revision "383"))
     (origin
       (method git-fetch)
       (uri (git-reference
@@ -166,11 +184,11 @@  (define lib-base-for-telegram-desktop
                   (git-version "0" revision commit)))
       (sha256
        (base32
-        "0vh5zgxwalmbnvz8lzlnba87ch8vnpmcz6nvf56w09f3nlxvvq78")))))
+        "16x5qp5w51igk213rhl49x256vjvpkjkgi2ziwzxnsj0pzdd4y27")))))
 
 (define lib-crl-for-telegram-desktop
   (let ((commit "4e620bc383d032aadea8e6af02661f8c76695cec")
-        (revision "16"))
+        (revision "21"))
     (origin
       (method git-fetch)
       (uri (git-reference
@@ -184,8 +202,8 @@  (define lib-crl-for-telegram-desktop
         "17bngj247qwq0dg4h37xdi5v1mk22y4yp7sp6ph3irmnz4awah0x")))))
 
 (define lib-lottie-for-telegram-desktop
-  (let ((commit "0770df009db7928df1d0cad0900dc5110106d229")
-        (revision "26"))
+  (let ((commit "6ed1c22ed60692d2f288c9222fafd7d5cd62f904")
+        (revision "61"))
     (origin
       (method git-fetch)
       (uri (git-reference
@@ -196,11 +214,11 @@  (define lib-lottie-for-telegram-desktop
                   (git-version "0" revision commit)))
       (sha256
        (base32
-        "1gj56ymlbk5dnk82jw674808m511lv9dky8891a5wm4gp3pph5jb")))))
+        "0l57ibfij9xm4ww4s9cc63q1x8xzpc6ablwaji1krrn3xxksqdd4")))))
 
 (define lib-qr-for-telegram-desktop
-  (let ((commit "2b08c71c6edcfc3e31f7d7f518cc963493b6e189")
-        (revision "7"))
+  (let ((commit "501f4c3502fd872ab4d777df8911bdac32de7c48")
+        (revision "10"))
     (origin
       (method git-fetch)
       (uri (git-reference
@@ -211,7 +229,7 @@  (define lib-qr-for-telegram-desktop
                   (git-version "0" revision commit)))
       (sha256
        (base32
-        "05hrkmwgrczyjv87r507i2r7m1zr6k2i43mq3my0s6j4szr1rjq0")))))
+        "0hmwqj7a9vcy8wq7pd1qprl68im3zl5f1wzcn2zzk2wvi0389k9f")))))
 
 (define lib-rlottie-for-telegram-desktop
   (let ((commit "0671bf70547381effcf442ec9618e04502a8adbc")
@@ -229,8 +247,8 @@  (define lib-rlottie-for-telegram-desktop
         "05qnza7j15356s8jq16pkbyp4zr586lssmd86lz5jq23lcb3raxv")))))
 
 (define lib-rpl-for-telegram-desktop
-  (let ((commit "df721be3fa14a27dfc230d2e3c42bb1a7c9d0617")
-        (revision "15"))
+  (let ((commit "fd31f5bf382d2679eccdb1abaf8240a56c6a7abe")
+        (revision "19"))
     (origin
       (method git-fetch)
       (uri (git-reference
@@ -241,11 +259,11 @@  (define lib-rpl-for-telegram-desktop
                   (git-version "0" revision commit)))
       (sha256
        (base32
-        "15fnv3ssn7rn5d0j52gggdvyqc2wm464678dj7v2x9h8lka2jjxn")))))
+        "1fpq8nyh8wx6zkb3sjjrx9ydqzyhw4483bdk1i9blp0ijn9xxdxf")))))
 
 (define lib-spellcheck-for-telegram-desktop
-  (let ((commit "68c9b788958904aea7de79f986a0f82ec8c5b094")
-        (revision "187"))
+  (let ((commit "0e386e22cb6ba8a114b569840a635e096dcb645e")
+        (revision "198"))
     (origin
       (method git-fetch)
       (uri (git-reference
@@ -256,11 +274,11 @@  (define lib-spellcheck-for-telegram-desktop
                   (git-version "0" revision commit)))
       (sha256
        (base32
-        "0d8s4wwk6fxf536mhzq2vb9qw3j0m8nqia7ylvvpsbc4kh09dadn")))))
+        "06js7ccv6z3nbd4v2p4hp2prrlmz5ww46y3yb922pp7gm317dwyw")))))
 
 (define lib-storage-for-telegram-desktop
-  (let ((commit "403df6c4a29562bd417c92d410e49819f5a48cc1")
-        (revision "20"))
+  (let ((commit "839609369d04615475cb1518636de3619106a917")
+        (revision "22"))
     (origin
       (method git-fetch)
       (uri (git-reference
@@ -271,11 +289,11 @@  (define lib-storage-for-telegram-desktop
                   (git-version "0" revision commit)))
       (sha256
        (base32
-        "1zxvzfrxbj4d395fzyb5pm9wn3n8jyimxx88cyqjcdd46sx4h7r5")))))
+        "1l26h2fmqp9dcpr6pfvdd5sjb68j7yh0ms2lnr8na7jf5xqmkwwm")))))
 
 (define lib-tl-for-telegram-desktop
-  (let ((commit "45faed44e7f4d11fec79b7a70e4a35dc91ef3fdb")
-        (revision "24"))
+  (let ((commit "36fb95c4de1339d2c8921ad6b2911858c3d0e0fa")
+        (revision "42"))
     (origin
       (method git-fetch)
       (uri (git-reference
@@ -286,11 +304,11 @@  (define lib-tl-for-telegram-desktop
                   (git-version "0" revision commit)))
       (sha256
        (base32
-        "0h43xvzklda02494d466jp52hl8c1kmav9f12dyld10dpf1w6c7m")))))
+        "03rngnssnqwr7ad05qn64mwgji5fb0r3fp5ybkf951p8phr1jvzk")))))
 
 (define lib-ui-for-telegram-desktop
-  (let ((commit "1b590f9e16eb9571a039f072d6fea66c607e419f")
-        (revision "508"))
+  (let ((commit "f82162f05a72352bfee0fb79f9e50c350b3a98f3")
+        (revision "917"))
     (origin
       (method git-fetch)
       (uri (git-reference
@@ -301,7 +319,7 @@  (define lib-ui-for-telegram-desktop
                   (git-version "0" revision commit)))
       (sha256
        (base32
-        "0ighyhfp29h9h8c7vr70pnhcv2xnsr9ln084pssn8hb5z4pmb62f")))))
+        "1zv29i7hxv70dsq36zrvkvaraff5zcb7sccpncqfl51s59kfsnz5")))))
 
 (define lib-waylandshells-for-telegram-desktop
   (let ((commit "59b0ee55a68976d27f1bf7cec0e11d5939e185e7")
@@ -319,8 +337,8 @@  (define lib-waylandshells-for-telegram-desktop
         "0l2xrpc5mvvdlsj333pmkgfvn9wi1ijfdaaz8skfnw9icw52faaf")))))
 
 (define lib-webrtc-for-telegram-desktop
-  (let ((commit "ef49f953f12b112008a094a719f40939aaf39db4")
-        (revision "72"))
+  (let ((commit "9b11599c3c56047cfa4c68b69f1fcc93b602c33a")
+        (revision "83"))
     (origin
       (method git-fetch)
       (uri (git-reference
@@ -331,11 +349,11 @@  (define lib-webrtc-for-telegram-desktop
                   (git-version "0" revision commit)))
       (sha256
        (base32
-        "15k4xs3462p3ddp5cn9im3nvdiaijmxir8wxsf5yrj70ghy26ibw")))))
+        "0158jx8hj4fv6qpw5pgcr2mdlihj0dxs060dg3iy61zz6q68z5dq")))))
 
 (define lib-webview-for-telegram-desktop
-  (let ((commit "e06427c624515485774e2e2181d4afeb05ad5a67")
-        (revision "40"))
+  (let ((commit "546df65eb2424550ed84ce14fc9c5d1bb3586f35")
+        (revision "76"))
     (origin
       (method git-fetch)
       (uri (git-reference
@@ -346,11 +364,11 @@  (define lib-webview-for-telegram-desktop
                   (git-version "0" revision commit)))
       (sha256
        (base32
-        "148z7xzfscynwwwqssdsd97npax6yn8zrd64xw8qzbwff2g2r7k4")))))
+        "0zzjwyw82bggncmmsw969lnjl04pklmqjqm77jjzadinivl52z0l")))))
 
 (define cmake-helpers-for-telegram-desktop
-  (let ((commit "4d44d822e01b3b5fbec3ce824e01f56aa35d7f72")
-        (revision "261"))
+  (let ((commit "b9f1b6036329e44ec61f51f0b363fe2319158b84")
+        (revision "444"))
     (origin
       (method git-fetch)
       (uri (git-reference
@@ -361,7 +379,7 @@  (define cmake-helpers-for-telegram-desktop
                   (git-version "0" revision commit)))
       (sha256
        (base32
-        "0h6cjiqy014h2mz90h1z5a7plb3ihbnds4bja8994ybr1dy3m7m5")))))
+        "0sgp1nlmcm2imgpssqxrwinafnmicmq0qikgdnhs1d44hrwxbws3")))))
 
 (define-public webrtc-for-telegram-desktop
   (let ((commit "621f3da55331733bf0d1b223786b96b68c03dca1")
@@ -456,8 +474,8 @@  (define-public webrtc-for-telegram-desktop
          license:bsd-3))))))
 
 (define-public rlottie-for-telegram-desktop
-  (let ((commit "cbd43984ebdf783e94c8303c41385bf82aa36d5b")
-        (revision "671"))
+  (let ((commit "8c69fc20cf2e150db304311f1233a4b55a8892d7")
+        (revision "678"))
     (hidden-package
      (package
        (inherit rlottie)
@@ -473,21 +491,12 @@  (define-public rlottie-for-telegram-desktop
           (file-name
            (git-file-name "rlottie-for-telegram-desktop" version))
           (sha256
-           (base32 "1lxpbgbhps9rmck036mgmiknqrzpjxpas8n7qxykv6pwzn0c8n0c"))))
-       (arguments
-        `(#:configure-flags
-          (list
-           "-Dlog=true"
-           "-Ddumptree=true"
-           "-Dtest=true")
-          #:phases
-          (modify-phases %standard-phases
-            (add-after 'unpack 'patch-cxx-flags
-              (lambda _
-                (substitute* "meson.build"
-                  (("werror=true")
-                   "werror=false"))
-                #t)))))))))
+           (base32 "14gwg3sn6xdx9ymnx5r0vfm4pk8dwk92s10a1wdvfbjpyrxll64i"))
+          (modules '((guix build utils)))
+          (snippet
+           #~(begin
+               (substitute* "meson.build"
+                 (("werror=true") "werror=false"))))))))))
 
 (define-public libtgvoip-for-telegram-desktop
   (let ((commit "13a5fcb16b04472d808ce122abd695dbf5d206cd")
@@ -533,7 +542,7 @@  (define-public libtgvoip-for-telegram-desktop
 (define-public telegram-desktop
   (package
     (name "telegram-desktop")
-    (version "2.9.3")
+    (version "4.2.0")
     (source
      (origin
        (method git-fetch)
@@ -545,15 +554,19 @@  (define-public telegram-desktop
        (file-name
         (git-file-name name version))
        (sha256
-        (base32 "0dzf1y3xhqvizg29bd1kya48cjbkq073d2x10ynwcmmx396l4nd8"))
+        (base32 "16xhng5m3aw4j4ax74nydpxjnx5z3ga21vmrznlm4lbk9ivyn7vx"))
+       (patches
+        (search-patches
+         ;; https://github.com/telegramdesktop/tdesktop/pull/24126
+         "telegram-desktop-allow-disable-libtgvoip.patch"))
        (modules '((guix build utils)
                   (ice-9 ftw)
                   (srfi srfi-1)))
        (snippet
         #~(begin
             (let ((keep
-                   '( ;; Not available in Guix.
-                     "SPMediaKeyTap" "statusnotifieritem" "tgcalls")))
+                   '(;; Not available in Guix.
+                     "dispatch" "tgcalls")))
               (with-directory-excursion "Telegram/ThirdParty"
                 (for-each delete-file-recursively
                           (lset-difference string=?
@@ -573,23 +586,22 @@  (define-public telegram-desktop
              (ice-9 match))
            #:configure-flags
            #~(list
-              ;; Client applications must provide their own API-ID and API-HASH,
-              ;; see also <https://core.telegram.org/api/obtaining_api_id>.
-              ;; Here, we snarf the keys from the official Snaps, which are
-              ;; also stored in <#$source/snap/snapcraft.yaml>.
+              ;; Client applications need an API ID and hash, see also:
+              ;; <https://core.telegram.org/api/obtaining_api_id>. Here, we
+              ;; use the ones given by the official Snap package, see:
+              ;; <https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml>.
               "-DTDESKTOP_API_ID=611335"
               "-DTDESKTOP_API_HASH=d524b414d21f4d37f08684c1df41ac9c"
-              ;; Disable WebkitGTK support as it fails to link
-              "-DDESKTOP_APP_DISABLE_WEBKITGTK=ON"
-              ;; Use bundled fonts as fallback.
-              "-DDESKTOP_APP_USE_PACKAGED_FONTS=OFF")
+              "-DTDESKTOP_DISABLE_LEGACY_TGVOIP=ON"
+              "-DDESKTOP_APP_DISABLE_CRASH_REPORTS=ON"
+              "-DDESKTOP_APP_DISABLE_AUTOUPDATE=ON"
+              "-DDESKTOP_APP_USE_PACKAGED_RLOTTIE=ON"
+              (string-append "-DTDESKTOP_LAUTCHER_BASENAME=" #$name))
            #:phases
            #~(modify-phases %standard-phases
-               (add-after 'unpack 'make-writable
-                 (lambda _
-                   (for-each make-file-writable (find-files "."))))
-               (add-after 'make-writable 'copy-inputs
+               (add-after 'unpack 'unpack-additional-sources
                  (lambda _
+                   (for-each make-file-writable (find-files "."))
                    (for-each
                     (match-lambda
                       ((dst src)
@@ -601,81 +613,73 @@  (define-public telegram-desktop
                       ("Telegram/lib_crl" #$lib-crl-for-telegram-desktop)
                       ("Telegram/lib_lottie" #$lib-lottie-for-telegram-desktop)
                       ("Telegram/lib_qr" #$lib-qr-for-telegram-desktop)
-                      ("Telegram/lib_rlottie" #$lib-rlottie-for-telegram-desktop)
                       ("Telegram/lib_rpl" #$lib-rpl-for-telegram-desktop)
                       ("Telegram/lib_spellcheck" #$lib-spellcheck-for-telegram-desktop)
                       ("Telegram/lib_storage" #$lib-storage-for-telegram-desktop)
                       ("Telegram/lib_tl" #$lib-tl-for-telegram-desktop)
                       ("Telegram/lib_ui" #$lib-ui-for-telegram-desktop)
-                      ("Telegram/lib_waylandshells" #$lib-waylandshells-for-telegram-desktop)
                       ("Telegram/lib_webrtc" #$lib-webrtc-for-telegram-desktop)
                       ("Telegram/lib_webview" #$lib-webview-for-telegram-desktop)
+                      ("Telegram/ThirdParty/dispatch" #$dispatch-for-telegram-desktop)
                       ("Telegram/ThirdParty/tgcalls" #$tgcalls-for-telegram-desktop)))))
-               (add-before 'configure 'patch-cxx-flags
-                 (lambda _
-                   (substitute* "cmake/options_linux.cmake" (("class-memaccess") "all"))))
                (add-after 'install 'glib-or-gtk-compile-schemas
                  (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
                (add-after 'glib-or-gtk-compile-schemas 'glib-or-gtk-wrap
                  (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
     (native-inputs
-     (list cmake-shared
-           extra-cmake-modules
-           `(,glib "bin")
+     (list `(,glib "bin")
            `(,gtk+ "bin")
+           clang-toolchain
            pkg-config
-           python-wrapper
-           qttools-5))
+           python-wrapper))
     (inputs
-     (list alsa-lib
+     (list abseil-cpp-cxxstd17
+           alsa-lib
            c++-gsl
-           catch2
-           libexpected
-           fcitx-qt5
-           fcitx5-qt
            ffmpeg
-           glib
-           glibmm-2.64
-           gtk+
-           hime
-           hunspell
            jemalloc
-           kwayland
-           libdbusmenu-qt
+           kcoreaddons
+           libexpected
            libjpeg-turbo
-           libtgvoip-for-telegram-desktop
-           lz4
-           materialdecoration
+           libvpx
            minizip
-           nimf
            openal
            openssl
            opus
            pulseaudio
            qrcodegen-cpp
-           qtbase-5
-           qtsvg-5
-           qt5ct
+           qt5compat
+           qtbase
            qtimageformats
-           qtwayland
+           qtsvg-5
            range-v3
            rlottie-for-telegram-desktop
            rnnoise
            webrtc-for-telegram-desktop
-           libx11
-           libxcb
-           xcb-util-keysyms
            xxhash
-           zlib))
-    (propagated-inputs (list dconf))
+           zlib
+           ;; DESKTOP_APP_DISABLE_DBUS_INTEGRATION
+           glibmm-2.64
+           ;; DESKTOP_APP_DISABLE_SPELLCHECK
+           hunspell
+           ;; DESKTOP_APP_LOTTIE_USE_CACHE
+           lz4
+           ;; DESKTOP_APP_DISABLE_WAYLAND_INTEGRATION
+           qtwayland wayland
+           ;; DESKTOP_APP_DISABLE_X11_INTEGRATION
+           libxcb xcb-util-keysyms
+           ;; Optional
+           webkitgtk))
     (synopsis "Telegram Desktop")
     (description "Telegram desktop is the official desktop version of the
 Telegram instant messenger.")
     (home-page "https://desktop.telegram.org/")
     (license
      (list
-      ;; ThirdParty
-      license:lgpl2.1+
+      ;; Telegram/ThirdParty/dispatch
+      license:asl2.0
+      ;; Telegram/ThirdParty/tgcalls
+      license:lgpl3
       ;; Others
       license:gpl3+))))