diff mbox series

[bug#57058] gnu: Add python-lief.

Message ID y76pmhahjo1.wl-hako@ultrarare.space
State Accepted
Headers show
Series [bug#57058] gnu: Add python-lief. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hilton Chain Aug. 8, 2022, 2:52 p.m. UTC
From 2d62c631996a97f98b4a1e7f383db87bb5b960a8 Mon Sep 17 00:00:00 2001
From: Hilton Chain <hako@ultrarare.space>
Date: Mon, 8 Aug 2022 22:50:45 +0800
Subject: [PATCH] gnu: Add python-lief.

* gnu/packages/python-xyz.scm (python-lief): New variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: ec6499aad231b8a5991f38c1ec982be4b3598837

Comments

Mathieu Othacehe Aug. 11, 2022, 3:37 p.m. UTC | #1
Hey,

> * gnu/packages/python-xyz.scm (python-lief): New variable.

This looks fine to me, but compilation takes a long time and appears to
be mono-threaded. I found that nix has the following snippet:

--8<---------------cut here---------------start------------->8---
    substituteInPlace setup.py \
      --replace 'cmake_args = []' "cmake_args = [ \"-DCMAKE_INSTALL_PREFIX=$prefix\" ]"
    ${pyEnv.interpreter} setup.py --sdk build --parallel=$NIX_BUILD_CORES
--8<---------------cut here---------------end--------------->8---

that can maybe allow parallel compilation?

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b6ca32a757..300aa2b52a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30353,3 +30353,25 @@  (define-public i3-autotiling
      "Script for Sway and i3 to automatically switch the horizontal/vertical
  window split orientation.")
     (license license:gpl3)))
+
+(define-public python-lief
+  (package
+    (name "python-lief")
+    (version "0.12.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/lief-project/LIEF")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1xzbh3bxy4rw1yamnx68da1v5s56ay4g081cyamv67256g0qy2i1"))))
+    (build-system python-build-system)
+    (native-inputs (list cmake))
+    (home-page "https://github.com/lief-project/LIEF")
+    (synopsis "Library to instrument executable formats")
+    (description
+     "LIEF is a cross platform library which can parse, modify and abstract ELF,
+PE and MachO formats.")
+    (license license:asl2.0)))