diff mbox series

[bug#59043] gnu: Add kconfig-hardened-check.

Message ID y76pme14qqb.wl-hako@ultrarare.space
State New
Headers show
Series [bug#59043] gnu: Add kconfig-hardened-check. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Hilton Chain Nov. 5, 2022, 10:53 a.m. UTC
* gnu/packages/linux.scm (kconfig-hardened-check): New variable.
---
 gnu/packages/linux.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)


base-commit: e67f9d7ab0c4bc957a918987a347a9ca429f3b0a

Comments

Christopher Baines Nov. 6, 2022, 2:12 p.m. UTC | #1
Hilton Chain via Guix-patches via <guix-patches@gnu.org> writes:

> +    (home-page "https://github.com/a13xp0p0v/kconfig-hardened-check")
> +    (synopsis
> +     "Tool for checking the security hardening options of the Linux kernel")
> +    (description
> +     "Tool for checking the security hardening options of the Linux kernel.")

This looks generally OK to me, but could you have a go at writing a
description that's different to the synopsis?

Even just wording it slightly differently would be OK (e.g. "The
@code{kconfig-hardened-check} tool helps with checking the security
hardening options of the Linux kernel").

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index cf11a7fc1b..3aa5613a15 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9512,3 +9512,24 @@  (define-public tp-smapi-module
 @acronym{SMAPI, System Management Application Program Interface} and direct
 access to the embedded controller.")
     (license license:gpl2+)))
+
+(define-public kconfig-hardened-check
+  (package
+    (name "kconfig-hardened-check")
+    (version "0.5.17")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/a13xp0p0v/kconfig-hardened-check")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0p9pywfxwyk4yfgaf7bhqrf72ywc6w6k77dbi7lldynha886ih4a"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/a13xp0p0v/kconfig-hardened-check")
+    (synopsis
+     "Tool for checking the security hardening options of the Linux kernel")
+    (description
+     "Tool for checking the security hardening options of the Linux kernel.")
+    (license license:gpl3)))