diff mbox series

[bug#57587] gnu: python-apsw: Update to 3.39.2.1.

Message ID y76bkru1qvc.wl-hako@ultrarare.space
State Accepted
Headers show
Series [bug#57587] gnu: python-apsw: Update to 3.39.2.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hilton Chain Sept. 5, 2022, 2:45 a.m. UTC
From 71d63d8824c860becb8975c63c6438ca437c168d Mon Sep 17 00:00:00 2001
From: Hilton Chain <hako@ultrarare.space>
Date: Mon, 5 Sep 2022 10:38:19 +0800
Subject: [PATCH] gnu: python-apsw: Update to 3.39.2.1.

* gnu/packages/databases.scm (python-apsw): Update to 3.39.2.1.
[arguments]: Use bundled Makefile.
---
 gnu/packages/databases.scm | 19 +++++++++++--------
 1 file changed, 11 insertions(+), 8 deletions(-)


base-commit: d22a5c18517d662516fc93889534367fd3a448f2
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 7edf0fed2d..741e582264 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3568,7 +3568,7 @@  (define-public python-pickleshare
 (define-public python-apsw
   (package
     (name "python-apsw")
-    (version "3.39.2.0")
+    (version "3.39.2.1")
     (source
      (origin
        (method git-fetch)
@@ -3578,20 +3578,23 @@  (define-public python-apsw
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0q7fnk8n3m5mpjzh6xyhj409k8sacdbjsfis98my9c50fdn5sr7y"))))
+         "1pdlmzyn0xnks4iwd99crralpbnli78c28zh000ha8dz4qbr0nsv"))))
     (build-system python-build-system)
     (inputs (list sqlite-next))         ;SQLite 3.39 required.
     (arguments
      (list #:phases
            #~(modify-phases %standard-phases
-               (replace 'build
+               (add-before 'build 'disable-fetch
                  (lambda _
-                   (invoke "python" "setup.py" "build" "--enable-all-extensions"
-                           "--enable=load_extension")))
-               (add-after 'build 'build-test-helper
+                   (substitute* "Makefile"
+                     (("fetch.*--all") ""))))
+               (replace 'build
                  (lambda _
-                   (invoke "gcc" "-fPIC" "-shared" "-o" "./testextension.sqlext"
-                           "-I." "-Isqlite3" "src/testextension.c"))))))
+                   (invoke "make" "build_ext")))
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (invoke "make" "test")))))))
     (home-page "https://github.com/rogerbinns/apsw/")
     (synopsis "Another Python SQLite Wrapper")
     (description