@@ -30353,3 +30353,26 @@ (define-public i3-autotiling
"Script for Sway and i3 to automatically switch the horizontal/vertical
window split orientation.")
(license license:gpl3)))
+
+(define-public python-misskey
+ (package
+ (name "python-misskey")
+ (version "4.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/YuzuRyo61/Misskey.py")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rma8pdsjsy00cg76q6q4qki4xpldykmz1m6dl3w2bjjxfhlbaz5"))))
+ (build-system python-build-system)
+ (arguments (list #:tests? #f)) ;needs network
+ (propagated-inputs (list python-requests))
+ (home-page "https://misskeypy.readthedocs.io")
+ (synopsis "Python bindings for Misskey's API")
+ (description
+ "This package provides access to Misskey's API. Misskey is a SNS platform
+using the ActivityPub protocol.")
+ (license license:expat)))
From f1581118f0594ab62b155e93d8a85aa19494b07c Mon Sep 17 00:00:00 2001 From: Hilton Chain <hako@ultrarare.space> Date: Mon, 8 Aug 2022 16:29:36 +0800 Subject: [PATCH] gnu: Add python-misskey. * gnu/packages/python-xyz.scm (python-misskey): New variable. --- gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++ 1 file changed, 23 insertions(+) base-commit: 19592539e54902097ec0a5a16ba38f41a687236c