diff mbox series

[bug#58886,1/2] gnu: eglexternalplatform: Add native-search-paths field.

Message ID y76a65dc217.wl-hako@ultrarare.space
State New
Headers show
Series [bug#58886,1/2] gnu: eglexternalplatform: Add native-search-paths field. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Hilton Chain Oct. 30, 2022, 5:29 a.m. UTC
* gnu/packages/xorg.scm (eglexternalplatform): Add native-search-paths field.
---
 gnu/packages/xorg.scm | 4 ++++
 1 file changed, 4 insertions(+)


base-commit: 63bf06013820aa26aca7dc8f18cb79403b94e9a5
diff mbox series

Patch

diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index a6b7b71d1d..54f5863d17 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5302,6 +5302,10 @@  (define-public eglexternalplatform
                           (string-append out "/samples")
                           (string-append out "/COPYING")
                           (string-append out "/README.md")))))))))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "__EGL_EXTERNAL_PLATFORM_CONFIG_DIRS")
+            (files '("share/egl/egl_external_platform.d")))))
     (synopsis "EGL External Platform interface")
     (description "EGLExternalPlatform is an specification of the EGL External
 Platform interface for writing EGL platforms and their interactions with modern