diff mbox series

[bug#57675,v6,05/11] gnu: telegram-desktop: Change API ID.

Message ID y764jx2oy7d.wl-hako@ultrarare.space
State Accepted
Headers show
Series gnu: telegram-desktop: Update to 4.2.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hilton Chain Sept. 20, 2022, 3:35 p.m. UTC
* gnu/packages/telegram.scm (telegram-desktop) [#:configure-flags]: Use API ID
from Telegram's official Snap builds.
---
 gnu/packages/telegram.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

--
2.37.3
diff mbox series

Patch

diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index 41d12161f0..8eea3297c7 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -502,12 +502,12 @@  (define-public telegram-desktop
              (guix build utils)
              (ice-9 match))
            #:configure-flags
-           #~`(;; Client applications must provide their own API-ID and API-HASH,
-               ;; see also <https://core.telegram.org/api/obtaining_api_id>.
-               ;; In case, that the credentials below fail to work, contact
-               ;;   Raghav Gururajan <rg@raghavgururajan.name>
-               "-DTDESKTOP_API_ID=2791056"
-               "-DTDESKTOP_API_HASH=582d6d0b44f7a2de949e99271fd8b3f2"
+           #~`(;; Client applications need an API ID and hash, see also:
+               ;; <https://core.telegram.org/api/obtaining_api_id>. Here, we
+               ;; use the ones given by the official Snap package, see:
+               ;; <https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml>.
+               "-DTDESKTOP_API_ID=611335"
+               "-DTDESKTOP_API_HASH=d524b414d21f4d37f08684c1df41ac9c"
                ;; Disable WebkitGTK support as it fails to link
                "-DDESKTOP_APP_DISABLE_WEBKITGTK=ON"
                ;; Use bundled fonts as fallback.