[bug#62373] gnu: Add python-pdoc.
Commit Message
Hi there,
I've packaged pdoc, a documentation system for python.
Thanks & best regards,
Ontje
From 8a6adf3add637fd3d04fa2dee3b413f5dd65fd06 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ontje=20L=C3=BCnsdorf?= <ontje.luensdorf@dlr.de>
Date: Wed, 22 Mar 2023 09:42:09 +0100
Subject: [PATCH] gnu: Add python-pdoc.
* gnu/packages/python-xyz.scm (python-pdoc): New variable.
---
gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)
@@ -135,6 +135,7 @@
;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
;;; Copyright © 2023 Amade Nemes <nemesamade@gmail.com>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
+;;; Copyright © 2023 Ontje Lünsdorf <ontje.luensdorf@dlr.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -915,6 +916,40 @@ (define-public python-mkdocs-markdownextradata-plugin
variables into the markdown template")
(license license:expat)))
+(define-public python-pdoc
+ (package
+ (name "python-pdoc")
+ (version "13.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/mitmproxy/pdoc")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0gxkw607nrd67ck4w8jri9vfrm5g60qvp8b134m8zkiphbxjnx0l"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest python-jinja2 python-pygments))
+ (arguments
+ (list
+ ;; Some tests fail, presumably because of slight version mismatches of
+ ;; the dependencies.
+ #:test-flags
+ '(list "-k" (string-append "not test_var_with_raising_repr and "
+ "not test_smoke[mock] and "
+ "not test_snapshots[html"))))
+ (home-page "https://pdoc.dev/")
+ (synopsis "API Documentation for Python Projects")
+ (description "pdoc auto-generates API documentation that follows your
+project's Python module hierarchy. It requires no configuration, has
+first-class support for type annotations, cross-links between identifiers,
+comes with an integrated live-reloading web server, uses customizable HTML
+templates, understands numpydoc and Google-style docstrings, and is
+permissively licensed.")
+ (license license:unlicense)))
+
(define-public python-py4j
(package
(name "python-py4j")
--
2.39.2