diff mbox series

[bug#56542] gnu: Add python-django-cleanup.

Message ID xagcat1kZc0pGtxkxgjzCSrKzNja-9gtncKZaWS663jq4WQ_IplAheO6lgMIqAmgs6BmOPoIxFjeRarX0suOzjpaWFsLgWcEzKKNqBStwYA=@protonmail.com
State Accepted
Headers show
Series [bug#56542] gnu: Add python-django-cleanup. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Luis Felipe July 13, 2022, 4:50 p.m. UTC
Hi, a new package here.


---
Luis Felipe López Acevedo
https://luis-felipe.gitlab.io/

Comments

Luis Felipe Aug. 22, 2022, 8:39 p.m. UTC | #1
Ping ◠ ◯
Marius Bakke Aug. 29, 2022, 3:59 p.m. UTC | #2
Luis Felipe via Guix-patches via <guix-patches@gnu.org> skriver:

> Hi, a new package here.

[...]

> * gnu/packages/django.scm (python-django-cleanup): New variable.

Applied, thanks!
diff mbox series

Patch

From 16f5e77b90c262e672ac7c32b25911518a4f1743 Mon Sep 17 00:00:00 2001
From: Luis Felipe <luis.felipe.la@protonmail.com>
Date: Wed, 13 Jul 2022 11:23:02 -0500
Subject: [PATCH] gnu: Add python-django-cleanup.

* gnu/packages/django.scm (python-django-cleanup): New variable.
---
 gnu/packages/django.scm | 51 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 51 insertions(+)

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index b32faab183..7f2783d071 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -1361,3 +1361,54 @@  (define-public python-django-svg-image-form-field
 models that use Django's standard @code{ImageField}, in addition to the
 image files already supported by it.")
     (license license:expat)))
+
+(define-public python-django-cleanup
+  (package
+    (name "python-django-cleanup")
+    (version "6.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/un1t/django-cleanup")
+             (commit (string-append version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0c1nghn1bnlq0a4d3sy3s363ksqsnxksixbimdy3cc6a0vk4sjps"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-tests-settings
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; django-cleanup optionally integrates with
+             ;; sorl-thumbnail, which is not available in Guix yet, so
+             ;; this patch comments it out to avoid import failures in
+             ;; test settings.
+             (substitute* "django_cleanup/testapp/settings.py"
+               (("'sorl\\.thumbnail',") "# 'sorl.thumbnail',"))))
+         (replace 'check
+           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               ;; Add CWD to PYTHONPATH so that the tests can find the
+               ;; testapp package in the source.
+               (setenv "PYTHONPATH" (getcwd))
+               (invoke "pytest")))))))
+    (native-inputs
+     (list ;; python-django-sorl-thumbnail  ; TODO: Add to Guix.
+           python-easy-thumbnails
+           python-pillow
+           python-pytest
+           python-pytest-cov
+           python-pytest-django
+           python-pytest-xdist))
+    (propagated-inputs
+     (list python-django))
+    (home-page "https://github.com/un1t/django-cleanup")
+    (synopsis "Automatically deletes unused media files")
+    (description "This application automatically deletes user-uploaded
+files when a model is modified or deleted.  It works for FileField,
+ImageField and their subclasses.  Files set as default values for any
+FileField are not deleted.")
+    (license license:expat)))
-- 
2.36.1