diff mbox series

[bug#48899,v2,1/2] gnu: Add lowdown.

Message ID xU42LNhtt1IRudiGRCXfqGMP3k3sCmMeUZfyap0QxUl4Ke7UEbEoJ6qDJPjKA1UuUj8bA6csxgJa_1g9pmqTcucvSvcjZa0eWMgnjEQJGpc=@protonmail.com
State Accepted
Headers show
Series [bug#48899,v2,1/2] gnu: Add lowdown. | expand

Commit Message

phodina Nov. 5, 2021, 5:48 a.m. UTC
Hi Zhu,

thanks for the patch. However, your patch was missing some imports as well as in the meantime a new version was released.

I also created one more patch to add prefix to all licenses in this module.

Petr

----8<--------cut here ------------------>8------------

* gnu/packages/markup.scm (lowdown): New variable.

--
2.33.1

Comments

Liliana Marie Prikler Nov. 5, 2021, 8:39 p.m. UTC | #1
Hi Petr,

Am Freitag, den 05.11.2021, 05:48 +0000 schrieb phodina:
> Hi Zhu,
> 
> thanks for the patch. However, your patch was missing some imports as
> well as in the meantime a new version was released.
> 
> I also created one more patch to add prefix to all licenses in this
> module.
> 
> Petr
> 
> ----8<--------cut here ------------------>8------------
This blurb should go below the changelog...

> * gnu/packages/markup.scm (lowdown): New variable.
> 
Here after two dashes ("--")

> diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
> index 368976bfde..720bdb178b 100644
> --- a/gnu/packages/markup.scm
> +++ b/gnu/packages/markup.scm
> @@ -7,6 +7,8 @@
>  ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
>  ;;; Copyright © 2020 EuAndreh <eu@euandre.org>
>  ;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
> +;;; Copyright © 2021 Zhu Zihao <all_but_last@163.com>
> +;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -34,12 +36,14 @@ (define-module (gnu packages markup)
>    #:use-module (guix build-system perl)
>    #:use-module (guix build-system python)
>    #:use-module (guix utils)
> +  #:use-module (gnu packages base)
>    #:use-module (gnu packages compression)
>    #:use-module (gnu packages)
>    #:use-module (gnu packages perl)
>    #:use-module (gnu packages pkg-config)
>    #:use-module (gnu packages python)
> -  #:use-module (gnu packages web))
> +  #:use-module (gnu packages web)
> +  #:use-module ((guix licenses) #:prefix license:))
> 
>  (define-public hoedown
>    (package
> @@ -114,6 +118,36 @@ (define-public markdown
>      (license (non-copyleft "file://License.text"
>                             "See License.text in the
> distribution."))))
> 
> +(define-public lowdown
> +  (package
> +    (name "lowdown")
> +    (version "0.10.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "
> https://kristaps.bsd.lv/lowdown/snapshots/lowdown-"
> +                           version ".tar.gz"))
> +       (sha256
> +        (base32
> "2f6lpyz5bbvwqadal8xcfjcm46zcycrgk5079isjyipg85zdyvb2"))))
Please provide a proper hash next time you update the version on
someone's behalf.
> +    (build-system gnu-build-system)
> +    (arguments
> +     `(#:tests? #f                      ;No test
There are actually regress tests.
> +       #:phases
> +       (modify-phases %standard-phases
> +         (replace 'configure
> +           (lambda* (#:key outputs #:allow-other-keys)
> +             (let ((out (assoc-ref outputs "out")))
> +               (invoke "./configure"
> +                       (string-append "PREFIX=" out)
> +                       (string-append "MANDIR=" out
> "/share/man"))))))))
> +    (native-inputs
> +     `(("which" ,which)))
> +    (home-page "https://kristaps.bsd.lv/lowdown/")
> +    (synopsis "Simple Markdown translator")
> +    (description "Lowdown is a Markdown translator producing HTML5,
> +roff documents in the ms and man formats, LaTeX, gemini, and
> terminal output.")
> +    (license license:isc)))
> +

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 368976bfde..720bdb178b 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -7,6 +7,8 @@ 
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 EuAndreh <eu@euandre.org>
 ;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
+;;; Copyright © 2021 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -34,12 +36,14 @@  (define-module (gnu packages markup)
   #:use-module (guix build-system perl)
   #:use-module (guix build-system python)
   #:use-module (guix utils)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
-  #:use-module (gnu packages web))
+  #:use-module (gnu packages web)
+  #:use-module ((guix licenses) #:prefix license:))

 (define-public hoedown
   (package
@@ -114,6 +118,36 @@  (define-public markdown
     (license (non-copyleft "file://License.text"
                            "See License.text in the distribution."))))

+(define-public lowdown
+  (package
+    (name "lowdown")
+    (version "0.10.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://kristaps.bsd.lv/lowdown/snapshots/lowdown-"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "2f6lpyz5bbvwqadal8xcfjcm46zcycrgk5079isjyipg85zdyvb2"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f                      ;No test
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (invoke "./configure"
+                       (string-append "PREFIX=" out)
+                       (string-append "MANDIR=" out "/share/man"))))))))
+    (native-inputs
+     `(("which" ,which)))
+    (home-page "https://kristaps.bsd.lv/lowdown/")
+    (synopsis "Simple Markdown translator")
+    (description "Lowdown is a Markdown translator producing HTML5,
+roff documents in the ms and man formats, LaTeX, gemini, and terminal output.")
+    (license license:isc)))
+
 (define-public discount
   (package
     (name "discount")