diff mbox series

[bug#59725] gnu: paulxstretch: Fix paths

Message ID wJriO_lL55pzPPL83h0IDGRTN8jXx6wdLuUXn0RxEHXJlnHa2GdixQiM8QRAnhn7Y4TwBsEcQLiXc48_W7-kP1KYx9R6TaAva1QvFC4KP2s=@proton.me
State New
Headers show
Series [bug#59725] gnu: paulxstretch: Fix paths | expand

Commit Message

Sughosha Nov. 30, 2022, 3:04 p.m. UTC
* gnu/packages/music.scm (paulxstretch): Fix paths.
[arguments]: Add phase fix-paths.
[inputs]: Add dconf and glib:bin.
---
 gnu/packages/music.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)

Comments

Ludovic Courtès Jan. 5, 2023, 9:48 p.m. UTC | #1
Hi Sughosha,

Apologies for the delay!

Sughosha <Sughosha@proton.me> skribis:

> * gnu/packages/music.scm (paulxstretch): Fix paths.
> [arguments]: Add phase fix-paths.
> [inputs]: Add dconf and glib:bin.

That’s a welcome fix.

>             #~(modify-phases %standard-phases
> +               (add-after 'unpack 'fix-paths
> +                          (lambda _
> +                            (substitute* "deps/juce/extras/Projucer/Source/ProjectSaving/jucer_ProjectExport_CodeBlocks.h"
> +                              (("/usr/include/freetype2")
> +                               (string-append #$freetype "/include/freetype")))
> +                            (substitute* "deps/juce/modules/juce_graphics/native/juce_linux_Fonts.cpp"
> +                              (("/etc/fonts")
> +                               (string-append #$fontconfig "/etc/fonts")))
> +                            (substitute* "deps/juce/modules/juce_gui_basics/native/x11/juce_linux_XWindowSystem.cpp"
> +                              (("/usr/bin/dconf")
> +                               (string-append #$dconf "/bin/dconf"))
> +                              (("/usr/bin/gsettings")
> +                               (string-append (ungexp glib "bin")
> +                                              "/bin/gsettings")))))

Could you avoid direct references to packages like #$freetype and
instead use ‘search-input-file’ and ‘search-input-directory’?

  (search-input-directory inputs "/etc/fonts")
  (search-input-file inputs "/bin/gsettings")
  …

There are examples in the repo on how to use them.

Could you send a v2 of the patch to 59725@debbugs.gnu.org?

Thanks in advance,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index b69ad2e517..eb15a9f825 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2481,6 +2481,20 @@  (define-public paulxstretch
      (list #:tests? #f                            ;no test suite
            #:phases
            #~(modify-phases %standard-phases
+               (add-after 'unpack 'fix-paths
+                          (lambda _
+                            (substitute* "deps/juce/extras/Projucer/Source/ProjectSaving/jucer_ProjectExport_CodeBlocks.h"
+                              (("/usr/include/freetype2")
+                               (string-append #$freetype "/include/freetype")))
+                            (substitute* "deps/juce/modules/juce_graphics/native/juce_linux_Fonts.cpp"
+                              (("/etc/fonts")
+                               (string-append #$fontconfig "/etc/fonts")))
+                            (substitute* "deps/juce/modules/juce_gui_basics/native/x11/juce_linux_XWindowSystem.cpp"
+                              (("/usr/bin/dconf")
+                               (string-append #$dconf "/bin/dconf"))
+                              (("/usr/bin/gsettings")
+                               (string-append (ungexp glib "bin")
+                                              "/bin/gsettings")))))
                (replace 'install
                  (lambda _
                    (let* ((bin (string-append #$output "/bin"))
@@ -2507,6 +2521,8 @@  (define-public paulxstretch
     (native-inputs (list pkg-config))
     (inputs (list alsa-lib
                   curl
+                  dconf
+                  `(,glib "bin")
                   fftwf
                   freetype
                   jack-1