diff mbox series

[bug#56724] gnu: Fix pcsc-lite missing input: python

Message ID wIZGwKqWaYJjJlNbbBA1M13kaUYIqBMZioVnthfsnWY-zsnkO5aMgsOgHsEjLgiwMpY4e_hNONMGAmDsSzfl_jxLnv7AVdHWmEbJ4HapScA=@protonmail.com
State Accepted
Headers show
Series [bug#56724] gnu: Fix pcsc-lite missing input: python | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Maya July 23, 2022, 2:17 p.m. UTC
The pcsc-lite package had an dependency for pcsc-spy command. This command requires python3 to be executable. This was however not declared in inputs of this package.
---
 gnu/packages/security-token.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

--
2.37.0

Comments

\( July 23, 2022, 2:20 p.m. UTC | #1
LGTM

  -- (
M July 23, 2022, 2:22 p.m. UTC | #2
On 23-07-2022 16:17, Maya via Guix-patches via wrote:
> -     `(("libudev" ,eudev)))
> +     `(("python3" ,python)
> +       ("libudev" ,eudev)))


Can be simplified to (list python eudev).

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 74ea57137f..586e9cbc8d 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -242,7 +242,8 @@  (define-public pcsc-lite
      (list perl ; for pod2man
            pkg-config))
     (inputs
-     `(("libudev" ,eudev)))
+     `(("python3" ,python)
+       ("libudev" ,eudev)))
     (home-page "https://pcsclite.apdu.fr/")
     (synopsis "Middleware to access a smart card using PC/SC")
     (description