diff mbox series

[bug#51920] gnu: Add inkbox.

Message ID wGmep6ZhN8O7zQCG0Ef_9N_7thDBSi1NHnT1S3qh-0Y2dyWWANWKgCirnKjpSv4G83EXKTjJIPuD5MOR7DQF6Q4YQuJ3yis6S-xz3GzRrPA=@protonmail.com
State Accepted
Headers show
Series [bug#51920] gnu: Add inkbox. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Nov. 17, 2021, 11:50 a.m. UTC
* gnu/packages/qt.scm (inkbox): New variable.

--
2.33.0

Comments

Nicolas Goaziou Nov. 21, 2021, 8:52 p.m. UTC | #1
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/qt.scm (inkbox): New variable.

Thank you. Some comments follow.

First, this should go to "ebook.scm" instead of "qt.scm".

> +    (source (origin

You should instead a newline before "(origin".

> +              (method git-fetch)
> +              (uri
> +               (git-reference
> +                (url "https://alpinekobox.ddns.net/InkBox/inkbox/")
> +                (commit version)))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "126cqn0ixcn608lv2hd9f7zmzj4g448bnpxc7wv9cvg83qqajh5n"))))

Nitpick: hash should go on the same line as base32.

> +    (build-system qt-build-system)
> +    (arguments
> +     '(#:tests? #f

You should add a comment explaining why tests are disabled (i.e.: there
is no tests).

> +       #:phases
> +       (modify-phases %standard-phases
> +         (add-after 'unpack 'prefix-opt
> +           (lambda* _
> +             (substitute* "inkbox.pro"
> +               (("/opt/\\$\\$\\{TARGET\\}") (string-append (assoc-ref %outputs "out"))))))

You should use (lambda* (#:key outputs #:allow-other-keys) ...) and then
(assoc-ref outputs "out") instead.

> +         (replace 'configure
> +           (lambda* (#:key make-flags #:allow-other-keys)
> +             (apply invoke (cons "qmake" make-flags)))))))
> +    (native-inputs
> +     `(("qtbase" ,qtbase-5)))

Does it fail with qtbase 6?

> +    (license license:gpl1)))

License is actually gpl3, according to LICENSE file.

Could you send an updated patch?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 4625d2220d..0f1744d8e8 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -3021,6 +3021,42 @@  (define-public python-pyside-2-tools
      "Contains lupdate, rcc and uic tools for PySide2")
     (license license:gpl2)))

+(define-public inkbox
+  (package
+    (name "inkbox")
+    (version "1.7")
+    (source (origin
+              (method git-fetch)
+              (uri
+               (git-reference
+                (url "https://alpinekobox.ddns.net/InkBox/inkbox/")
+                (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "126cqn0ixcn608lv2hd9f7zmzj4g448bnpxc7wv9cvg83qqajh5n"))))
+    (build-system qt-build-system)
+    (arguments
+     '(#:tests? #f
+       #:make-flags
+       (list (string-append "PREFIX="
+                            (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'prefix-opt
+           (lambda* _
+             (substitute* "inkbox.pro"
+               (("/opt/\\$\\$\\{TARGET\\}") (string-append (assoc-ref %outputs "out"))))))
+         (replace 'configure
+           (lambda* (#:key make-flags #:allow-other-keys)
+             (apply invoke (cons "qmake" make-flags)))))))
+    (native-inputs
+     `(("qtbase" ,qtbase-5)))
+    (home-page "https://alpinekobox.ddns.net/InkBox/inkbox/")
+    (synopsis "EBook reader")
+    (description "This package provides InkBox eBook reader.")
+    (license license:gpl1)))
+
 (define-public libqglviewer
   (package
     (name "libqglviewer")