diff mbox series

[bug#57702,v4,1/8] gnu: Add rust-nic-emoji-char-0.9.

Message ID w8hqA0e-9mO7UGNEfPngx2qvMkPbsacSXaORGmS0ztm2o-MljCEJaSQzzdh7CtUnWeU6EVNHxN6PtH-0fm5dbjrp_VF3-G_C9L_6QC9f5eE=@protonmail.com
State New
Headers show
Series [bug#57702,v4,1/8] gnu: Add rust-nic-emoji-char-0.9. | expand

Commit Message

VesselWave Sept. 10, 2022, 9:38 a.m. UTC
Sorry previous v3 was't different. Now it deletes tables directory. I hope it's enough
[PATCH 1/8] gnu: Add rust-unic-emoji-char-0.9.

---
 gnu/packages/crates-io.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

--
2.37.2

Comments

M Sept. 11, 2022, 11:37 a.m. UTC | #1
On 10-09-2022 11:38, VesselWave via Guix-patches via wrote:
> Sorry previous v3 was't different. Now it deletes tables directory. I hope it's enough
> [PATCH 1/8] gnu: Add rust-unic-emoji-char-0.9.

I've looked at the source code, and it seems to use the tables, without 
regenerating them.  As such, 'rust-unic-emoji-char' cannot be built 
(except for the #:skip-build? #true).  IIUC, the only reason that having 
this rust-unic-emoji-char be a dependency of rust-textwrap works, is 
that it is a test-only (optional!) input and it has #:skip-build? #true.

My proposal then is to:

   * for now, not package rust-unic-emoji-char
     (as it appears to be non-functional)
   * comment-out the rust-unic-emoji-char from the
     #:cargo-development-inputs
   * if this causes build failures because of Cargo not finding the
     source code of rust-unic-emoji-char, remove the input from
     rust-textwrap's Cargo.toml.

> +                          (delete-file-recursively "tables") #t))))

Returning #t isn't necessary anymore.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 02f7bc7d4d..a130651c0b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -69234,6 +69234,32 @@  (define-public rust-unic-common-0.9
 Internationalization Crates (UNIC) project.")
     (license (list license:expat license:asl2.0))))

+(define-public rust-unic-emoji-char-0.9
+  (package
+    (name "rust-unic-emoji-char")
+    (version "0.9.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "unic-emoji-char" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0ka9fr7s6lv0z43r9xphg9injn35pfxf9g9q18ki0wl9d0g241qb"))
+              (modules '((guix build utils)))
+              (snippet '(begin
+                          (delete-file-recursively "tables") #t))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-unic-char-range" ,rust-unic-char-range-0.9)
+                       ("rust-unic-property-char" ,rust-unic-char-property-0.9)
+                       ("rust-unic-ucd-version" ,rust-unic-ucd-version-0.9))))
+    (home-page "https://github.com/open-i18n/rust-unic/")
+    (synopsis "Emoji character properties for UNIC")
+    (description "This package provides emoji character properties and for
+the Unicode and Internationalization Crates (UNIC) project.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-unic-segment-0.9
   (package
     (name "rust-unic-segment")