diff mbox series

[bug#45059] gnu: freecad: Fix compilation flags

Message ID uukVWlWfdHgU2ykwn4t7VL8W2LnsEMneaz6ezoA0HHafPMBpWNLk-0WqMyzJmGYM-vNYBFMN7udZIFZ851kgAitatvvYf-yjE6QhbaK18Og=@elenq.tech
State Accepted
Headers show
Series [bug#45059] gnu: freecad: Fix compilation flags | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Ekaitz Zarraga Dec. 5, 2020, 11:51 p.m. UTC
Hi everyone,

I managed to solve the longstanding issue with freecad's compilation (#43448).

I'll submit a new change with the package update to 0.18.5 next.

Thanks



From d4d8a65679406b212c68d5198f239bdd71395541 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Sun, 6 Dec 2020 00:43:36 +0100
Subject: [PATCH] gnu: freecad: Fix compilation flags

    * gnu/packages/engineering.scm (freecad)[arguments]: Set correct
    search paths in compilation flags. Fixes #43448
---
 gnu/packages/engineering.scm | 24 ++++++++++++++++++++++--
 1 file changed, 22 insertions(+), 2 deletions(-)

--
2.28.0

Comments

Marius Bakke Dec. 6, 2020, 9:29 p.m. UTC | #1
Ekaitz Zarraga <ekaitz@elenq.tech> skriver:

> Hi everyone,
>
> I managed to solve the longstanding issue with freecad's compilation (#43448).
>
> I'll submit a new change with the package update to 0.18.5 next.

Thanks a lot for these patches Ekaitz!

I pushed them both with 383f087cd74316d26c5c0f19b73bc620312c5477.
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 558541dd5a..5a8977c940 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2496,8 +2496,28 @@  full programmatic control over your models.")
        #:configure-flags
        (list
         "-DBUILD_QT5=ON"
-        (string-append "-DCMAKE_INSTALL_LIBDIR="
-                       (assoc-ref %outputs "out") "/lib"))
+        (string-append "-DCMAKE_INSTALL_LIBDIR=" (assoc-ref %outputs "out") "/lib")
+
+        (string-append "-DPYSIDE2UICBINARY="
+                       (assoc-ref %build-inputs "python-pyside-2-tools")
+                       "/bin/uic")
+        (string-append "-DPYSIDE2RCCBINARY="
+                       (assoc-ref %build-inputs "python-pyside-2-tools")
+                       "/bin/rcc")
+
+        "-DPYSIDE_LIBRARY=PySide2::pyside2"
+        (string-append
+         "-DPYSIDE_INCLUDE_DIR="
+         (assoc-ref %build-inputs "python-pyside-2") "/include;"
+         (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2;"
+         (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2/QtCore;"
+         (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2/QtWidgets;"
+         (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2/QtGui;")
+
+        "-DSHIBOKEN_LIBRARY=Shiboken2::libshiboken"
+        (string-append "-DSHIBOKEN_INCLUDE_DIR="
+                       (assoc-ref %build-inputs "python-shiboken-2")
+                       "/include/shiboken2"))
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'restore-pythonpath