diff mbox series

[bug#49702,v3] gnu: Add swaylock-effects.

Message ID unDKb1hl1TC0nrOh3T-sINFfnz_1PwO-ag40T0svdOON6e6JxZwJoac-IEQiDH68K7UObeogISq4yP6CY4C69u6gFArBONdk1RjauWJCDG0=@protonmail.com
State Accepted
Headers show
Series [bug#49702,v3] gnu: Add swaylock-effects. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina Sept. 18, 2021, 12:52 p.m. UTC
* gnu/packages/wm.scm (swaylock-effects): New variable.

--
2.32.0

Comments

Liliana Marie Prikler Sept. 18, 2021, 1:29 p.m. UTC | #1
Pushed with the following changes:

Am Samstag, den 18.09.2021, 12:52 +0000 schrieb phodina:
> * gnu/packages/wm.scm (swaylock-effects): New variable.
> 
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 957c5a0d5a..1cc68388b8 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -83,6 +83,7 @@
>    #:use-module (gnu packages bison)
>    #:use-module (gnu packages build-tools) ;for meson-0.55
>    #:use-module (gnu packages calendar)
> +  #:use-module (gnu packages commencement) ; for gcc>9
Dropped, wouldn't be needed as (gnu packages gcc) is already imported.
>    #:use-module (gnu packages datastructures)
>    #:use-module (gnu packages docbook)
>    #:use-module (gnu packages documentation)
> @@ -1617,6 +1618,31 @@ modules for building a Wayland compositor.")
>      (description "Swaylock is a screen locking utility for Wayland
> compositors.")
>      (license license:expat))) ; MIT license
> 
> +(define-public swaylock-effects
> +  (let ((commit "5cb9579faaf5662b111f5722311b701eff1c1d00")
> +        (revision "1"))
> +    (package (inherit swaylock)
> +             (name "swaylock-effects")
> +             (version commit)
Used git-version.
> +             (source (origin
> +                       (method git-fetch)
> +                       (uri (git-reference
> +                             (url "
> https://github.com/mortie/swaylock-effects")
> +                             (commit version)))
Used commit.
> +                       (file-name (git-file-name name version))
> +                       (sha256
> +                        (base32
> +                         "036dkhfqgk7g9vbr5pxgrs66h5fz0rwdsc67i1w51a
> a9v01r35ca"))))
> +             ; Requires gcc>=9 see the issue here
> +             ; https://github.com/mortie/swaylock-effects/issues/26
> +             (native-inputs `(("gcc", gcc-9)
> +                              ,@(package-native-inputs swaylock)))
Dropped, instead configured and patched to not use SSE or mtune=native
for the sake of reproducible builds.
> +             (synopsis "Screen locking utility for Wayland
> compositors with effects")
> +             (description "@code{Swaylock-effects} is a fork of
> swaylock with additional
> +features, such as the ability to take a screenshot as the background
> image,
> +display a clock or apply image manipulation techniques to the
> background image.")
> +             (home-page "https://github.com/mortie/swaylock-effects"
> ))))
Indentation fixed.

Thanks
phodina Oct. 30, 2021, 9:26 p.m. UTC | #2
Hi,

I'm just going through my open tickets and this one seems to be already merged in commit 511dc6877e0664d83fd800cc601fa94c231a0d0f.

Could you please confirm and close the ticket?
Liliana Marie Prikler Oct. 30, 2021, 9:35 p.m. UTC | #3
Am Samstag, den 30.10.2021, 21:26 +0000 schrieb phodina:
> Hi,
> 
> I'm just going through my open tickets and this one seems to be
> already merged in commit 511dc6877e0664d83fd800cc601fa94c231a0d0f.
> 
> Could you please confirm and close the ticket?
Indeed, I CC'd the wrong address when I pushed it.
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 957c5a0d5a..1cc68388b8 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -83,6 +83,7 @@ 
   #:use-module (gnu packages bison)
   #:use-module (gnu packages build-tools) ;for meson-0.55
   #:use-module (gnu packages calendar)
+  #:use-module (gnu packages commencement) ; for gcc>9
   #:use-module (gnu packages datastructures)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages documentation)
@@ -1617,6 +1618,31 @@  modules for building a Wayland compositor.")
     (description "Swaylock is a screen locking utility for Wayland compositors.")
     (license license:expat))) ; MIT license

+(define-public swaylock-effects
+  (let ((commit "5cb9579faaf5662b111f5722311b701eff1c1d00")
+        (revision "1"))
+    (package (inherit swaylock)
+             (name "swaylock-effects")
+             (version commit)
+             (source (origin
+                       (method git-fetch)
+                       (uri (git-reference
+                             (url "https://github.com/mortie/swaylock-effects")
+                             (commit version)))
+                       (file-name (git-file-name name version))
+                       (sha256
+                        (base32
+                         "036dkhfqgk7g9vbr5pxgrs66h5fz0rwdsc67i1w51aa9v01r35ca"))))
+             ; Requires gcc>=9 see the issue here
+             ; https://github.com/mortie/swaylock-effects/issues/26
+             (native-inputs `(("gcc", gcc-9)
+                              ,@(package-native-inputs swaylock)))
+             (synopsis "Screen locking utility for Wayland compositors with effects")
+             (description "@code{Swaylock-effects} is a fork of swaylock with additional
+features, such as the ability to take a screenshot as the background image,
+display a clock or apply image manipulation techniques to the background image.")
+             (home-page "https://github.com/mortie/swaylock-effects"))))
+
 (define-public swaybg
   (package
     (name "swaybg")