diff mbox series

[bug#60857] Include missing patches

Message ID ui-Ec9yhOU19T7FYMvzaB6527wuoRNowA9a_C3zNNPn4KzIEkRyvKrYxJO9tcad9UxIaqCyiFKfIyXJMB2AfwP8daVyGRNpaDlXJXe1NtGg=@protonmail.com
State New
Headers show
Series [bug#60857] Include missing patches | expand

Commit Message

phodina Feb. 8, 2023, 2:37 p.m. UTC
Hi,

here are the patches. Unfortunately, they were not included from the original message.

----
Petr
diff mbox series

Patch

From a396f110c1111527b6f06839e91ea89d1d1724c6 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Mon, 16 Jan 2023 11:41:00 +0100
Subject: [PATCH 2/2] gnu: Add python-injector.

* gnu/packages/python-xyz.scm (python-injector): New variable.

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a9e0981e9a..ebada3d15e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20228,6 +20228,31 @@  (define-public python-iniconfig
      @end itemize")
     (license license:expat)))
 
+(define-public python-injector
+  (package
+    (name "python-injector")
+    (version "0.20.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "injector" version))
+              (sha256
+               (base32
+                "0fi2zw6nffl91ihx25wfvr5mq8jyrdx2pa56wdhww2c35ydb8qc6"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-typing-extensions))
+    (native-inputs (list python-black
+                         python-check-manifest
+                         python-dataclasses
+                         python-mypy
+                         python-pytest
+                         python-pytest-cov))
+    (home-page "https://github.com/python-injector/injector")
+    (synopsis "Python dependency injection framework")
+    (description
+     "This package provides Python dependency injection framework - inspired by
+Guice.")
+    (license license:bsd-3)))
+
 (define-public python-mamba
   (package
     (name "python-mamba")
-- 
2.38.1