diff mbox series

[bug#47467] : Fix Blender missing Voxel Remesher (Follows)

Message ID uG-eQstvIag6z9SU0DuyUFdM0mHaikmIx073yXhDpdAsJt6Al9-6GXqD4x0qg96QrATE-5YZWEqV9uP-NYWK5cdKGzHavOtYNZKfevMx15c=@elenq.tech
State Accepted
Headers show
Series [bug#47467] : Fix Blender missing Voxel Remesher (Follows) | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Ekaitz Zarraga March 29, 2021, 6:17 p.m. UTC
Looks like Nix package I used as a reference has unneeded inputs.

This is the updated OpenVDB package.

:)
diff mbox series

Patch

From e868ccaee0db0b1cc267cf66cf8279f92263f1fe Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Mon, 29 Mar 2021 16:04:23 +0200
Subject: [PATCH 1/2] gnu: Add openvdb.

* gnu/packages/graphics.scm (openvdb): New variable.
---
 gnu/packages/graphics.scm | 42 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 4a301d387a..344d44fcbf 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -463,6 +463,48 @@  Embree is meant to increase performance of photo-realistic rendering
 applications.")
     (license license:asl2.0)))
 
+
+(define-public openvdb
+  (package
+      (name "openvdb")
+      (version "8.0.1")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/AcademySoftwareFoundation/openvdb/")
+                       (commit (string-append "v" version))
+                       (recursive? #t)))
+                (file-name (git-file-name name version))
+                (sha256
+                  (base32 "0qzx6l5c183k6j9zki31gg9aixf5s1j46wdi7wr1h3bz7k53syg9"))))
+      (arguments
+        `(#:phases
+          (modify-phases %standard-phases
+            (add-before 'configure 'fix-runpath
+              (lambda* (#:key outputs #:allow-other-keys)
+                (setenv
+                  "LDFLAGS"
+                  (string-append "-Wl,-rpath=" (assoc-ref outputs "out") "/lib/"))
+                #t)))))
+      (build-system cmake-build-system)
+      (native-inputs
+        `(("pkg-config",pkg-config)))
+      (inputs
+        `(("boost"    ,boost)
+          ("zlib"     ,zlib)
+          ("c-blosc"  ,c-blosc)
+          ("ilmbase"  ,ilmbase)
+          ("tbb"      ,tbb)))
+      (home-page "https://www.openvdb.org/")
+      (synopsis "Sparse volume data structure and tools")
+      (description "OpenVDB is an open source C++ library comprising a novel
+hierarchical data structure and a large suite of tools for the efficient
+storage and manipulation of sparse volumetric data discretized on
+three-dimensional grids.  It was developed by DreamWorks Animation for use in
+volumetric applications typically encountered in feature film production.")
+      (license license:mpl2.0)))
+
+
 (define-public blender
   (package
     (name "blender")
-- 
2.31.0