Commit Message
since isc-dhcp has been EOLd for about 2 years now i figured it was a good
opportunity to package ISC's kea-dhcp to officially start isc-dhcp's
deprecation in Guix.
Gabriel Wicki (2):
gnu: Add log4cplus.
gnu: Add kea-dhcp.
gnu/packages/admin.scm | 29 +++++++++++++++++++++++++++++
gnu/packages/logging.scm | 24 ++++++++++++++++++++++++
2 files changed, 53 insertions(+)
base-commit: 386080366c642d887f9156059e4e894cd2d4e9b1
@@ -59,6 +59,30 @@ (define-module (gnu packages logging)
#:use-module (gnu packages tcl)
#:use-module (gnu packages tls))
+(define-public log4cplus
+ (package
+ (name "log4cplus")
+ (version "2.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/log4cplus/log4cplus")
+ (commit (string-append
+ "REL_"
+ (string-replace-substring version "." "_")))
+ (recursive? #t)))
+ (sha256
+ (base32
+ "1h3inzfrg5j8wb3m7nf2bpyzwyzpxzg5mzxqwwqgkbplnl5whzfd"))))
+ (build-system gnu-build-system)
+ (home-page "https://log4cplus.github.io/log4cplus/")
+ (synopsis "Log library for C++")
+ (description
+ "log4cplus is a C++ library providing a logging API providing
+thread-safe, flexible and arbitrarily granular control over log management and
+configuration. It is modeled after the Log4j Java API.")
+ (license license:expat)))
+
(define-public log4cpp
(package
(name "log4cpp")