diff mbox series

[bug#49234] Add cl-markkup-reader

Message ID tu2BeALmum26ONCUy-98tiJE4g1wZMxt4sNVgwNwIn-CV0iVW3JsIkZ6Z0LJAs3kNSTucCLa3P-gktqFQhXzuF6SSPC44CBVNK0Jq-u0hzY=@protonmail.com
State Accepted
Headers show
Series [bug#49234] Add cl-markkup-reader | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Charles June 26, 2021, 3:36 p.m. UTC
Patch is attatched. Like last time, I'm still new to this and appreciate any feedback.

Comments

Guillaume Le Vaillant June 27, 2021, 9:16 a.m. UTC | #1
Patch pushed as 1afffdaa63d34a810943aa5a6b8cc03d42cc3bd2 with the
following modifications:
 - copyright line for you added
 - 'commit' and 'revision' declared at the top of the package definition
 - use of the 'git-version' function to define the version
 - '#:asd-files' argument removed as it is not necessary in this case
   (all the asd files are read by default)
 - "fiveam" added to native-inputs as it is required by the
   "markup.test" system
 - inputs sorted
 - synopsis shortened a little
 - commit message fixed (you wrote "fonts.scm" instead of "lisp-xyz.scm")

Thanks.
diff mbox series

Patch

From 0b18edbfc77292bb7dd55b70e0abcd9279a45c54 Mon Sep 17 00:00:00 2001
From: Charles <charles.b.jackson@protonmail.com>
Date: Sat, 26 Jun 2021 09:31:11 -0500
Subject: [PATCH] gnu: Add cl-markup-reader.

* gnu/packages/fonts.scm (sbcl-markup-reader): Add new variable.
* gnu/packages/fonts.scm (ecl-markup-reader): Add new variable.
* gnu/packages/fonts.scm (cl-markup-reader): Add new variable.
---
 gnu/packages/lisp-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 1bd35d5812..f8aae805ed 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -3591,6 +3591,43 @@  Lisp, featuring:
 (define-public ecl-cl-markup
   (sbcl-package->ecl-package sbcl-cl-markup))
 
+(define-public sbcl-markup-reader
+  (package
+    (name "sbcl-markup-reader")
+    (version "0.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/moderninterpreters/markup")
+             (commit "d2d4d7b073554f47c24223a9304452966608702e")))
+       (file-name (git-file-name "markup-reader" version))
+       (sha256
+        (base32 "0i3v938j8zpzkd6p9j8gadp5zndjcdxhswj1qgsp592v6497rpzj"))))
+    (build-system asdf-build-system/sbcl)
+    (arguments
+     '(#:asd-files '("markup.asd")
+       #:asd-systems '("markup")))
+    (inputs
+     `(("sbcl-cl-str" ,sbcl-cl-str)
+       ("sbcl-alexandria" ,sbcl-alexandria)
+       ("sbcl-named-readtables" ,sbcl-named-readtables)
+       ("sbcl-trivial-gray-streams" ,sbcl-trivial-gray-streams)))
+    (home-page "https://github.com/moderninterpreters/markup")
+    (synopsis "Markup provides a reader-macro to read HTML tags inside of
+Common Lisp code")
+    (description "Markup allows the use of HTML syntax with in Common Lisp code.
+This has the advantage of being able to copy HTML snippets and have the
+instantly be functional, less double quotes than a s-expression approach, and
+designers will be able to understand the embeded HTML.")
+    (license license:asl2.0)))
+
+(define-public ecl-markup-reader
+  (sbcl-package->ecl-package sbcl-markup-reader))
+
+(define-public cl-markup-reader
+  (sbcl-package->cl-source-package sbcl-markup-reader))
+
 (define-public sbcl-cl-mustache
   (package
     (name "sbcl-cl-mustache")
-- 
2.32.0