diff mbox series

[bug#60440,2/3] gnu: Add flat-remix-gtk-theme.

Message ID tla8VGh-m3hpWF36Sj49X__c0bJ3b1VcsdsA1_nzEFq536zhLPWE7dIHM_6_7zdDWZbPMgVOf27Z1njiwoLf_7bb3YM8Fy2VfxipdYJOFro=@proton.me
State New
Headers show
Series [bug#60440,1/3] gnu: Add flat-remix-icon-theme. | expand

Commit Message

Sughosha Dec. 30, 2022, 11:17 p.m. UTC
* gnu/packages/gnome-xyz.scm (flat-remix-gtk-theme): New public variable.
---
 gnu/packages/gnome-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 8734d087a8..30249e4c8b 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -253,6 +253,34 @@  (define-public flat-remix-icon-theme
 gradients for some depth.")
     (license license:gpl3+)))
 
+(define-public flat-remix-gtk-theme
+  (package
+    (name "flat-remix-gtk-theme")
+    (version "20220627")
+    (source
+      (origin
+        (method git-fetch)
+        (uri
+          (git-reference
+            (url "https://github.com/daniruiz/flat-remix-gtk")
+            (commit version)))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "1kwahlrcm9rfsrd97q9lsbfz5390qafwbv78zl6j2vqgqnxhpwng"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f
+       #:make-flags `(,(string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:phases
+        (modify-phases %standard-phases
+          (delete 'configure))))
+    (home-page "https://drasite.com/flat-remix-gtk")
+    (synopsis "GTK application theme with material design")
+    (description "Flat Remix GTK is a GTK application theme inspired by
+material design.  It is mostly flat using a colorful palette with some shadows,
+highlights, and gradients for some depth.")
+    (license license:gpl3+)))
+
 (define-public gnome-plots
   (package
     (name "gnome-plots")