diff mbox series

[bug#64673,3/3] gnu: quickjs: Honor the #:tests? flag.

Message ID tencent_FD05E53E258FB56A9B8BA95859DD7FC73A08@qq.com
State New
Headers show
Series fix quickjs building on riscv64-linux, use gexp, honor #:tests? flags . | expand

Commit Message

Z572 July 17, 2023, 4:10 a.m. UTC
* gnu/packages/javascript.scm (quickjs)[arguments]: Adjust custom
'check phase to honor the #:tests? flag.
---
 gnu/packages/javascript.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index b9ee5a93b3..1c37f73d75 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -828,8 +828,9 @@  (define-public quickjs
            #:phases #~(modify-phases %standard-phases
                         (delete 'configure)
                         (replace 'check
-                          (lambda _
-                            (invoke "make" "microbench"))))))
+                          (lambda* (#:key tests? #:allow-other-keys)
+                            (when tests?
+                              (invoke "make" "microbench")))))))
     (home-page "https://bellard.org/quickjs/")
     (synopsis "Small embeddable Javascript engine")
     (description "QuickJS supports the ES2020 specification including modules,